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 Introduction

To the Teacher

The CAD Instructor Guide and its supporting materials are designed to assist you in 
teaching SolidWorks in an academic setting. This guide offers a competency-based 
approach to teaching 3D design concepts and techniques.

Each lesson in the CAD Instructor Guide has corresponding pages in the CAD Student 
Guide (available as PDFs from the Design Library tab on the Task Pane. Expand 
SolidWorks Content, SolidWorks Educator Curriculum, Curriculum, SolidWorks 

Student Guide). The CAD Instructor Guide is annotated with discussion points, 
suggestions for class demonstrations, and explanatory information related to the exercises 
and projects. Also in this guide are answer keys for assessments, worksheets, and quizzes.

SolidWorks Tutorials

The CAD Instructor Guide is a companion resource and 
supplement for the SolidWorks Tutorials. Many of the 
exercises in the CAD Student Guide use material from the 
SolidWorks Tutorials.

Accessing the SolidWorks Tutorials

To start the SolidWorks Tutorials, click Help, SolidWorks 

Tutorials. The SolidWorks window is resized and a second 
window appears next to it with a list of the available tutorials. 
There are over 40 lessons in the SolidWorks Tutorials. As 
you move the pointer over the links, an illustration of the 
tutorial will appear at the bottom of the window. Click the 
desired link to start that tutorial.

TIP: When you use SolidWorks Simulation 
to perform static engineering analysis, 
click Help, SolidWorks Simulation, 
Tutorials to access over 50 lessons 
and over 80 verification problems. 
Click Tools, Add-ins to activate 
SolidWorks Simulation.



Introduction

vi CAD Instructor Guide

Conventions

Set your screen resolution to 1280x1024 for optimal viewing of the tutorials.

The following icons appear in the tutorials:

Moves to the next screen in the tutorial.

Represents a note or tip. It is not a link; the information is below the icon. Notes 
and tips provide time-saving steps and helpful hints.

You can click most buttons that appear in the lessons to flash the corresponding 
SolidWorks button.

Open File or Set this option automatically opens the file or sets the option.

A closer look at... links to more information about a topic. Although not required 
to complete the tutorial, it offers more detail on the subject.

Why did I... links to more information about a procedure, and the reasons for the 
method given. This information is not required to complete the tutorial.

Show me... demonstrates with a video.

Printing the SolidWorks Tutorials

If you like, you can print the SolidWorks Tutorials by following this procedure:

1 On the tutorial navigation toolbar, click Show.

This displays the table of contents for the SolidWorks Tutorials.

2 Right-click the book representing the lesson you wish to print and select Print... from 
the shortcut menu.

The Print Topics dialog box appears.

3 Select Print the selected heading and all subtopics, and click OK.

4 Repeat this process for each lesson that you want to print.

Educator Resources link

The Instructors Curriculum link on the SolidWorks Resources  tab of the Task 
Pane includes substantial supporting materials to aid in your course presentation. 
Accessing this page requires a login account for the SolidWorks Customer Portal. You can 
use this course as is or you can select the pieces of it that meet your class needs. These 
supporting materials afford you flexibility in scope, depth, and presentation.
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Before You Begin

If you have not done so already, copy the companion files for the lessons onto your 
computer before you begin this project.

1 Start SolidWorks.

Using the Start menu, start the SolidWorks application.

2 SolidWorks Content.

Click SolidWorks Resources  to open the SolidWorks 
Resources Task Pane.

Click on the Instructors Curriculum link which will take you 
to the SolidWorks Customer Portal web page.

Click Educator Resources, under Download. Accessing this 
page requires a login account for the SolidWorks Customer 
Portal.

Here you will find the zip file containing the teacher companion files: Teacher 
Lesson/Model Files.

3 Download the zip file.

4 Open the zip file.

Browse to the folder where you saved the zip file in step 3 and double-click the zip file.

5 Click Extract.

Browse to the location where you want to save the files. The system automatically 
creates folders for the sample files in whatever location you specify. For example, you 
might want to save it in My Documents.

Using This Course

This course is not just this book. The CAD Instructor Guide is the focal point of the 
SolidWorks course — the road map for it. The supporting materials that are on the 
Educator Resources link and the SolidWorks Tutorials give you a lot of flexibility in how 
you present the course.

Learning 3D design is an interactive process. Students learn best when they can explore 
the practical applications of the concepts that they learn. This course has many activities 
and exercises that enable students to put design concepts into practice. Using the provided 
files, they can do so quickly.

The lesson plans for this course are designed to balance lecture and hands-on learning. 
There are also assessments and quizzes that give you additional measures of student 
progress.

TIP: Remember the location of these files.
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Before Presenting the Lectures

� Verify that the SolidWorks software is loaded and running on your classroom/lab 
computers in accordance with your SolidWorks license.

� Download and unzip the files from the Educator Resources link.

� Print copies of Student’s Guide to Learning SolidWorks Software for each student.

� Work through each of the labs yourself. This is not only to verify that you understand 
how they work, but to explore. Often there are different ways to accomplish a task.

Lesson Plans

Each lesson plan contains the following components:

� Goals of the Lesson — Clear objectives for the lesson.

� Before Beginning the Lesson — Prerequisites, if any, for the current lesson.

� Resources for This Lesson — Tutorials that correspond to the lesson.

� Review of Previous Lesson — Students reflect back on the material and models 
described in the previous lesson with questions and examples. Ask these questions of 
your students to reinforce concepts. 

� Lesson Outline — Describes the major concepts explored in each lesson.

� Competencies — Lists the competencies that students develop as they learn the 
material presented in the lesson.

� In Class Discussion — Topics for discussion to explain some concepts in the lesson.

� Active Learning Exercises — Students create models. Some of these exercises are from 
Student’s Guide to Learning SolidWorks Software. Most are from the SolidWorks 
Tutorials. 

� 5-minute Assessments — These review the concepts developed in the outline of the 
lesson and the active learning exercises. Questions are presented in the Student 
Workbook and they may be answered in class or for homework. You can use the 5-
minute assessment questions as verbal or written exercises. Space is provided in the 
Student Workbook for answers. These are check points for students before they move 
on to the additional exercises and projects.

� Additional Exercises and Projects — Additional exercises and projects are at the end of 
each lesson. These exercises and projects were developed from suggestions made by 
students and teachers.

� More to Explore — Since students learn at different rates, some lessons also have 
advanced or related exercises that you can assign to all students or just students who 
have finished the other material of the lesson ahead of the class.

Note: Mathematics is also explored through a series of applied problems. For 
example: students design a coffee mug and determine how much liquid it 
holds. Does the answer make sense?



Introduction

CAD Instructor Guide ix

� Lesson Quizzes — Fill in the blank, true/false and short answer questions compose the 
lesson quizzes. The lesson quiz master and answer key are only available in the CAD 
Instructor Guide.

� Lesson Summary — Quick recap of the main points of the lesson.

� Microsoft® PowerPoint® Slides — There are prepared Microsoft PowerPoint slides to 
explain each lesson. These slides are provided to you electronically on the Educator 
Resources link. These reproducible pages can also be used to create handouts.

Syllabus

Here is an overview of the material covered in each lesson:

Lesson Outcome for Students Assessments

Lesson 1: Using the Interface • Become familiar with 

Microsoft Windows

• Become familiar with the 

SolidWorks user interface

• 5 minute assessment

• Vocabulary worksheet

• Lesson Quiz

Lesson 2: Basic Functionality • Develop an understanding of 

3D modeling and recognition 

of an object in 3D space

• Apply 2D sketch geometry, 

rectangle, circle, and 

dimensions

• Understand 3D features that 

add and remove geometry 

including Extruded Base, 

Extruded Cut, Fillet and Shell 

• Create the Box part

• 5 minute assessment

• Vocabulary worksheet

• Lesson Quiz

• Additional Exercises: Design a 

Switch Plate

• Optional materials for Switch 

Plate: Cardboard, construction 

paper or foam board 

120mmx80mm for each 

student, tape or glue, cutting 

tools, ruler 

• Optional materials for Box: For 

milled wood 

100mmx60mmx50mm for each 

box. (Note: Cardboard sheets 

and tape can also be used)
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Lesson 3: The 40-Minute Running 
Start

• Reinforce the understanding of 

3D features that add and 

remove geometry

• Apply 2D sketch geometry, 

rectangle, circle, and 

dimensions

• Create the Tutor1 part

• 5 minute assessment

• Unit conversion worksheet

• Material volume assessment

• Lesson Quiz

• Additional Exercises: 

Modifying the Tutor1 part

• Additional Exercises: CD Jewel 

Case and Storage Box parts

• Optional materials: cardboard 

or foam board, tape, wood (mill 

or precut pieces required) 

29mmx17mmx18mm for each 

storage box

Lesson 4: Assembly Basics • Develop an understanding of 

3D assembly modeling by 

combining Tutor1 part with 

Tutor2 part

• Apply 2D sketch tools to offset 

geometry and project geometry 

to the sketch plane

• Create Tutor2 part and Tutor 

assembly

• 5 minute assessment

• Vocabulary worksheet

• Lesson Quiz

• Review of fasteners selection

• Additional Exercises: Design a 

Switchplate assembly, Storage 

Box assembly, and Claw 

Mechanism assembly

• Optional materials: screws for 

switchplate part, roughly 

3.5mm diameter

• A variety of fasteners to discuss 

design and manufacturing 

parameters for a product

Lesson 5: SolidWorks Toolbox 
Basics

• Develop an understanding of 

SolidWorks Toolbox, a 

component library of standard 

parts 

• Understand how library 

components are utilized in an 

assembly

• Modify SolidWorks Toolbox 

part definitions and create new 

parts for the Toolbox library

• 5 minute assessment

• Vocabulary worksheet

• Lesson Quiz

• Assemble a standard Toolbox 

pan head screw to the 

switchplate

• Additional Exercises: Add 

fasteners to the bearing block 

assembly

• Optional materials: Variety of 

fasteners. For Switch Plate, #6-

32 Pan Head

Lesson 6: Drawing Basics • Understand basic drawing 

concepts

• Apply drawing standards to 

part and assembly drawings

• Create a drawing template

• Create Tutor1 drawing for part 

and assembly

• 5 minute assessment

• Lesson Quiz

• Additional Exercises: Create a 

drawing for Tutor2, the storage 

box, and the switchplate

Lesson Outcome for Students Assessments
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Lesson 7: SolidWorks eDrawings 
Basics

• Create eDrawings from existing 

SolidWorks files

• View and manipulate 

eDrawings

• Measure and markup 

eDrawings

• Create animations of 

eDrawings to display multiple 

views

• 5 minute assessment

• Vocabulary worksheet

• Lesson Quiz

• Additional Exercises: Create, 

explore and email eDrawings 

files

Lesson 8: Design Tables • Understand configurations

• Develop a Design Table with 

Microsoft Excel to create 

families of parts

• Explore how values in an Excel 

spreadsheet automatically 

change dimensions and features 

of an existing part to create 

multiple parts of different sizes

• 5 minute assessment

• Lesson Quiz

• Additional Exercises: Create a 

design table for Tutor2, the 

Tutor assembly, the storage 

box, and a cup

• Optional materials: cups, 

beakers in different size and a 

ruler

Lesson 9: Revolve and Sweep 
Features

• Understand 3D features that 

add and remove geometry 

including Revolve and Sweep

• Apply 2D sketch tools such as 

ellipse, trim and centerline

• Create the Candlestick part

• 5 minute assessment

• Lesson Quiz

• Additional Exercises: Create a 

candle and modify the 

switchplate

• Optional materials: cup, beaker, 

candle and a ruler

Lesson 10: Loft Features • Understand the 3D Loft feature 

created from multiple profiles 

sketched on different planes

• Create the Chisel part

• 5 minute assessment

• Lesson Quiz

• Additional Exercises: Create a 

bottle, a screwdriver, and a 

sports bottle

• Optional materials: screwdriver 

and simple bottle

Lesson Outcome for Students Assessments
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Supporting Course Materials

The following supporting course materials are provided to you via the Educators 
Resources link of the SolidWorks Customer Portal. Click the Instructors Curriculum 
link on the SolidWorks Resources  tab of the Task Pane to access:

� Student Guide - An electronic version of the Student’s Guide to Learning SolidWorks 
Software. It contains exercises, tutorials, projects, and worksheets. You can reproduce 
this book for use with your students.

� Student Lesson/Model Files - Parts, assemblies, and drawings that correspond to the 
activities and exercises in the Student’s Guide to Learning SolidWorks Software.

� Teacher Lesson/Model Files - Parts, assemblies, and drawings that correspond to the 
activities and exercises in this guide.

� CAD Instructor Guide - An electronic version of this guide.

� Instructor Presentation - These slides compliment the CAD Instructor Guide. You can 
project these slides directly on a screen, reproduce these as student handouts, and 
modify them to suit your needs. These slides are available as .PPT files.

Lesson 11: Visualization • Understand how to apply 

materials, scenes, and lights to 

create a photorealistic images 

in JPEG format

• Create an exploded view and 

develop an animation in AVI 

format

• 5 minute assessment

• Lesson Quiz

• Additional Exercises: Create a 

rendering of Tutor1, Tutor2 and 

Tutor assembly, create an 

exploded view, and create an 

animation of the nested slides 

assembly

• Optional materials: digital 

photographs and images

Lesson 12: SolidWorks 
Sustainability

• Understand basic concepts of 

sustainable design.

• Measure the environmental 

impacts of various design 

choices, including material, 

manufacture location, and more 

on the various parts and 

assemblies.

• 5 minute assessment

• Lesson Quiz

• Additional Exercises: Analyze 

the storagebox and determine 

the environmental impacts on 

various design choices.

Lesson 13: SolidWorks 
SimulationXpress

• Understand basic concepts of 

stress analysis

• Analyze parts to calculate 

factor of safety and maximum 

stress and displacement

• 5 minute assessment

• Lesson Quiz

• Additional Exercises: Analyze 

the storagebox and modify the 

storagebox to observe the 

effects on the maximum 

displacement

Lesson Outcome for Students Assessments
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Certified SolidWorks Associate (CSWA) Certification Program

The lessons, exercises, and projects in this course provide much of the background 
required for the Certified SolidWorks Associate (CSWA) Certification Program. The 
CSWA Certification Program provides the skills students need to work in the design and 
engineering fields. Successfully passing the CSWA Exam assessment proves competency 
in 3D CAD modeling technology, application of engineering principles, and recognition of 
global industry practices. Appendix A provides more information and a sample exam.

More Resources

The SolidWorks Education web site (http://www.solidworks.com/education) is a dynamic 
resource of information and updates for you. This site is focused on the needs of you — 
the instructor — and the resources that you need to modernize the way in which 
engineering design graphics is taught today.

The following table showcases many additional resources to help make the SolidWorks 
software easy to learn, use, and teach. You can access a PDF version of these resources at 
http://files.solidworks.com/datasheets/EDU_2011_Curriculum_Resources_DS_ENG.pdf.

Curriculum and Community Resources for Educators and Students

Curriculum Resources

SolidWorks Instructor Guides - A collection of tutorials and 
projects that utilize SolidWorks design and analysis tools. 
Includes the documents, PowerPoint presentations, movie files 
in reproducible format. (Login account required on SolidWorks 
Customer Portal.)

www.solidworks.com/curriculum

SolidWorks Student Guides - A collection of tutorials and 
projects that is available from within the SolidWorks Education 
Edition.

Select Help>Student Curriculum

SolidWorks Sustainability - Tutorials and PowerPoint 
presentation that introduce students to sustainable design and 
life cycle assessment (LCA). (Login account required on 
SolidWorks Customer Portal.)

www.solidworks.com/customerportal

Teacher Blog - A collection of lessons developed by teachers 
for teachers that use SolidWorks to reinforce concepts in 
science, technology, engineering and math concepts.

http://blogs.solidworks.com/teacher

Community Resources

3D Content Central - A library of part, assembly, drawing, 
blocks and macro files.

www.3DContentCentral.com

SolidWorks User Group Network - An independent 
community of local and regional SolidWorks users throughout 
the world.

www.swugn.org

SolidWorks Blog - The official SolidWorks blog and access to 
over 35 independent SolidWorks bloggers.

http://blogs.solidworks.com

SolidWorks User Network - A comprehensive resource forum 
on specific product areas.

http://forum.solidworks.com/

SolidWorks Sponsored Design Contests - SolidWorks supports 
thousands of students in design competitions in after school 
programs including FSAE/Formula Student teams, Robotics 
competitions, and Technology competitions.

www.solidworks.com/
SponsoredDesignContests



Introduction

xiv CAD Instructor Guide

Textbooks - Books based on SolidWorks software available 
from a variety of publishers.

www.amazon.com

www.delmarlearning.com 

www.g-w.com 

www.mhprofessional.com

www.pearsonhighered.com

www.sdcpublications.com

Video - YouTube playlists for Formula SAE/Formula Student, 
Certified SolidWorks Associate Exam (CSWA) and SolidWorks 
Tutorials.

www.youtube.com/solidworks

Certification

Certified SolidWorks Associate (CSWA) Exam Provider 
Program - The CSWA Provider Program is an engineering 
design competency based program that leads students to achieve 
certification through the Certified SolidWorks Associate 
(CSWA) Exam. Used by industry as a recommended 
competency for job placement and used by academia for 
assessment and articulation agreements. A desk copy of the 
CSWA Exam Preparation Guide is available through www.sdc

CSWA Provider Application: 
www.solidworks.com/CSWAProvider 

Sample CSWA exam:
www.solidworks.com/CSWA

Curriculum and Community Resources for Educators and Students
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 Lesson 1: Using the Interface

Goals of This Lesson

� Become familiar with the Microsoft Windows® interface.

� Become familiar with the SolidWorks user interface.

Before Beginning This Lesson

� Verify that Microsoft Windows is loaded and running on your classroom/lab computers.

� Verify that the SolidWorks software is loaded and running on your classroom/lab 
computers in accordance with your SolidWorks license.

� Load the lesson files from the Educator Resources link.

Outline of Lesson 1 

� Active Learning Exercise — Using the Interface

• Starting a Program

• Exiting a Program

• Opening an Existing File

• Saving a File

• Copying a File

• Resizing Windows

• SolidWorks Windows

• CommandManager

• Mouse Buttons

• Context-sensitive Shortcut Menus

• Getting Online Help

� Lesson Summary

Note: If your students are already experienced with the Microsoft Windows 
Graphical User Interface, you may wish to skip to the section of this lesson that 
familiarizes students with the SolidWorks user interface.

The CAD Instructor Guide provides additional examples, presentations, model files, and 
quizzes. Visit www.solidworks.com/customerportal for more.
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Competencies for Lesson 1 

Students develop the following competencies in this lesson:

� Engineering: Knowledge of an engineering design industry software application.

� Technology: Understand file management, copy, save, starting and exiting programs.

Active Learning Exercise — Using the Interface

Start the SolidWorks application, open a file, save the file, save the file with a new name, 
and review the basic user interface.

Starting a Program

1 Click the Start button  in the lower left corner of the window. The Start menu 
appears. The Start menu allows you to select the basic functions of the Microsoft 
Windows environment.

2 From the Start menu, click All Programs, SolidWorks, SolidWorks.

The SolidWorks application program is now running.

Exit the Program

To exit the application program, click File, Exit or click  on the main SolidWorks 
window. 

Opening an Existing File

3 Double-click on the SolidWorks part file Dumbell in the Lesson01 folder.

This opens the Dumbell file in SolidWorks. If the SolidWorks application program is 
not running when you double-click on the part file name, the system runs the 
SolidWorks application program and then opens the part file that you selected. 

You could have also opened the file by selecting File, Open, and typing or browsing to 
a file name or by selecting a file name from the File menu in SolidWorks. SolidWorks 
lists the last several files that you had open.

Saving a File

4 Click Save  on the Menu Bar to save changes to a file. 

It is a good idea to save the file that you are working whenever you make changes to it. 

Note: Click means to press and release the left mouse button.

TIP: A desktop shortcut is an icon that you can 
double-click to go directly to the file or folder 
represented. The illustration shows the 
SolidWorks shortcut.

TIP: Use the left mouse button to double-click. Double-
clicking with the left mouse button is often a quick way of 
opening files from a folder.
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Copying a File

Notice that Dumbell is not spelled 
correctly. It is supposed to have two 
“b’s”.

1 Click File, Save As to save a copy 
of the file with a new name. 

The Save As window appears. This 
window shows you in which folder 
the file is currently located, the file 
name, and the file type.

2 In the File Name field change the 
name to Dumbbell and click 
Save.

A new file is created with the new 
name. The original file still exists. 
The new file is an exact copy of the 
file as it exists at the moment that it 
is copied.

Resizing Windows

SolidWorks, like many applications, uses windows to show your work. You can change 
the size of each window.

1 Move the cursor along the edge of a window until the shape of the 
cursor appears to be a two-headed arrow.

2 While the cursor still appears to be a two-headed arrow, hold down 
the left mouse button and drag the window to a different size.

3 When the window appears to be the size that you wish, release the mouse button.

Windows can have multiple panels. You can resize these panels relative to each other.

4 Move the cursor along the border between two panels until the cursor 
appears to be two parallel lines with perpendicular arrows.

5 While the cursor still appears to be two parallel lines with perpendicular 
arrows, hold down the left mouse button and drag the panel to a different size.

6 When the panel appears to be the size that you wish, release the mouse button.

SolidWorks Windows

SolidWorks windows have two panels. One panel provides non-graphic data. The other 
panel provides graphic representation of the part, assembly, or drawing. 

The leftmost panel of the window contains the FeatureManager® design tree, 
PropertyManager and ConfigurationManager.

1 Click each of the tabs at the top of the left panel and see how the contents of the 
window changes. 
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The rightmost panel is the 
Graphics Area, where you 
create and manipulate the 
part, assembly, or drawing.

2 Look at the Graphics Area. 
See how the dumbbell is 
represented. It appears 
shaded, in color and in an 
isometric view. These are 
some of the ways in which 
the model can be 
represented very 
realistically.

CommandManager

The CommandManager is a context-sensitive toolbar that dynamically updates based on 
the functions you want to access. By default, it displays tabs that are based on the 
document type. Use the CommandManager to access functions in a central location and to 
save space for the graphics area.

When you click a tab in the control area, the CommandManager updates to show those 
tools. For example, if you click Sketch in the control area, the sketch tools appear in the 
CommandManager. The convention for using the CommandManager is to write, “Click 
Sketch > Smart Dimension .” In this convention, Sketch is the CommandManager 
tab and Smart Dimension is the tooltip.

Mouse Buttons

Mouse buttons operate in the following ways:

� Left – Selects menu items, entities in the graphics area, and objects in the 
FeatureManager design tree.

� Right – Displays the context-sensitive shortcut menus.

� Middle – Rotates, pans, and zooms the view of a part or an assembly, and pans in a 
drawing.

Model

Graphics
area

Left panel displaying the FeatureManager design tree

control area
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Shortcut Menus

Shortcut menus give you access to a wide variety of tools and commands while you work 
in SolidWorks. When you move the pointer over geometry in the model, over items in the 
FeatureManager design tree, or over the SolidWorks window borders, right-clicking pops 
up a shortcut menu of commands that are appropriate for wherever you clicked.

You can access the "more commands menu" by selecting the double-down arrows  in 
the menu. When you select the double-down arrows or pause the pointer over the double-
down arrows, the shortcut menu expands to offer more menu items.

The shortcut menu provides an efficient way to work without continually moving the 
pointer to the main pull-down menus or the CommandManager.

Getting Online Help

If you have questions while you are using the SolidWorks software, you can find 
answers in several ways:

� Click the flyout menu of Help options  in the menu bar.

� Click Help, SolidWorks Help.

� While in a command, click Help  in the dialog.
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Lesson 1 — 5 Minute Assessment — Answer Key

Name: _______________________________Class: _________ Date:_______________

Directions: Answer each question by writing the correct answer or answers in the space 

provided or circle the answer as directed.

1 How do you open the file from Windows Explorer?

Answer: Double-click on the file name.

2 How do you start the SolidWorks program?

Answer: Click , All Programs, SolidWorks, SolidWorks.

3 What is the quickest way to start the SolidWorks program?

Answer: Double-click the SolidWorks desktop shortcut (if one exists).

4 How do you copy a part within the SolidWorks program?

Answer: Click File, Save As and assign a new name.
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Lesson 1 — 5 Minute Assessment REPRODUCIBLE

Name: _______________________________Class: _________ Date:_______________

Directions: Answer each question by writing the correct answer or answers in the space 

provided or circle the answer as directed.

1 How do you open the file from Windows Explorer?

_____________________________________________________________________

2 How do you start the SolidWorks program?

_____________________________________________________________________

3 What is the quickest way to start the SolidWorks program?

_____________________________________________________________________

4 How do you copy a part within the SolidWorks program?

_____________________________________________________________________
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Lesson 1 Vocabulary Worksheet — Answer Key

Name: _______________________________Class: _________ Date:_______________

Fill in the blanks with the words that are defined by the clues.

1 Shortcuts for collections of frequently used commands: CommandManager tabs

2 Command to create a copy of a file with a new name: File, Save As

3 One of the areas that a window is divided into: panel

4 The graphic representation of a part, assembly, or drawing: model

5 Area of the screen that displays the work of a program: window

6 Icon that you can double-click to start a program: desktop shortcut

7 Action that quickly displays shortcut menus of frequently used or detailed commands: 
right-click

8 Command that updates your file with changes that you have made to it: File, Save

9 Action that quickly opens a part or program: double-click

10 The program that helps you create parts, assemblies, and drawings: SolidWorks

11 Panel of the SolidWorks window that displays a visual representation of your parts, 
assemblies, and drawings: graphics area
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Lesson 1 Vocabulary Worksheet REPRODUCIBLE

Name: _______________________________Class: _________ Date:_______________

Fill in the blanks with the words that are defined by the clues.

1 Shortcuts for collections of frequently used commands: ________________________ 

2 Command to create a copy of a file with a new name: __________________________

3 One of the areas that a window is divided into: _______________________________

4 The graphic representation of a part, assembly, or drawing: ______________________

5 Area of the screen that displays the work of a program: _________________________

6 Icon that you can double-click to start a program: _____________________________

7 Action that quickly displays shortcut menus of frequently used or detailed commands: 

_____________________________________________________________________

8 Command that updates your file with changes that you have made to it: ____________

_____________________________________________________________________

9 Action that quickly opens a part or program: _________________________________

10 The program that helps you create parts, assemblies, and drawings: _______________

11 Panel of the SolidWorks window that displays a visual representation of your parts, 
assemblies, and drawings: ________________________________________________
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Lesson 1 Quiz — Answer Key

Name: _______________________________Class: _________ Date:_______________

Directions: Answer each question by writing the correct answer or answers in the space 

provided or circle the answer as directed.

1 How do you start the SolidWorks application program?

Answer: Click , All Programs, SolidWorks, SolidWorks; or double-click on the 
SolidWorks desktop shortcut; or double-click on a SolidWorks file.

2 Which command would you use to create a copy of your file?

Answer: File, Save As

3 Where do you see a 3D representation of your model? 

Answer: Graphics Area.

4 Look at the illustration (at right). What is this collection of 
frequently used commands called?

Answer: CommandManager

5 Which command would you use to preserve changes that you 
have made to a file?

Answer: File, Save

6 Circle the cursor that is used to resize a window.

Answer: 

7 Circle the cursor that is used to resize a panel.

Answer: 

8 Circle the button that is used to get online help.

Answer: 
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Lesson 1 Quiz REPRODUCIBLE

Name: _______________________________Class: _________ Date:_______________

Directions: Answer each question by writing the correct answer or answers in the space 

provided or circle the answer as directed.

1 How do you start the SolidWorks application program?

_____________________________________________________________________

_____________________________________________________________________

2 Which command would you use to create a copy of your file? ____________________

3 Where do you see a 3D representation of your model? __________________________

4 Look at the illustration (at right). What is this collection of 
frequently used commands called?

5 Which command would you use to preserve changes that you have made to a file?

_____________________________________________________________________

6 Circle the cursor that is used to resize a window.

7 Circle the cursor that is used to resize a panel.

8 Circle the button that is used to get online help.
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Lesson Summary

� The Start menu is where you go to start programs or find files.

� There are short cuts such as right-click and double-click that can save you work.

� File, Save allows you to save updates to a file and File, Save As allows you to make a 
copy of a file.

� You can change the size and location of windows as well as panels within windows.

� The SolidWorks window has a Graphics Area that shows 3D representations of your 
models.
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Thumbnail Images of PowerPoint Slides

The following thumbnail images, arranged left to right, show the PowerPoint slides 
provided with this lesson.
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Using the Interface

� Use windows to view files.
� Use the mouse to select buttons, menus, and model elements.
� Run programs � like SolidWorks mechanical design software.
� Find, open, and work with files.
� Create, save, and copy files.

The interface is how you interact with the computer in the 
following ways:
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Microsoft® Windows®

� SolidWorks runs on 
the Microsoft 
Windows graphical 
user interface.

� Windows let you see 
the work of an 
application program.

� Panels are sub sections of windows.
� Illustration shows one window with two panels.
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Using the Mouse

� The mouse lets you move around the interface.
� The cursor is the pointer that shows you where the 

mouse is on the screen.
� Click the left mouse button to select commands, 

buttons, geometry, and other elements.
� Double-click the left mouse button to quickly open a file 

or folder.
� Click the right mouse button to access a shortcut menu 

of frequently used commands.
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Running Programs

� The quickest way to start a program is to double-click on 
a desktop shortcut.

� Some programs may not have desktop shortcuts.
� The Programs menu lists all of the application programs 

resident on the computer.
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Exit a Program

� Select or click File, Exit to end a program.
� If the file has unsaved changes, you have the chance to 

save the them before exiting.
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Opening a File

� The quickest way to open a file is to double-click on it.
� The File menu displays your most recently used files.
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Saving and Copying Files

� Saving a file preserves the changes 
that you have made to it.

� Use File, Save As to copy a file.
� File, Save As creates an exact duplicate of the file as it existed at 

the moment that you copied it.
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Resizing Windows

� Allows you to customize the appearance of your screen.
� View multiple files at the same time.
� Use                     to change the size of a window.
� Use              to change the size of panels within a window.
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Using the SolidWorks Interface

� SolidWorks windows 
display graphic and non-
graphic model data.

� CommandManager tabs 
display frequently used 
commands.
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Left Side of SolidWorks Window

� FeatureManager®  
design tree

� Property 
Manager

� Configuration  
Manager
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Right Side of SolidWorks Window

� SolidWorks Resources � Design Library

The Task Pane
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Right Side of SolidWorks Window

� Toolbox � File Explorer

The Task Pane
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CommandManager

� CommandManager tabs include buttons for frequently used 
commands.

� The visible tabs change based on the open document type: part, 
assembly, or drawing.

� The CommandManager is displayed at the top of the window.
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Getting Help

� Click      .
� Select Help, SolidWorks Help.
� Help displays in a separate window.

To view comprehensive online help:
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 Lesson 2: Basic Functionality

Goals of This Lesson

� Understand the basic functionality of the SolidWorks software.

� Create the following part:

Before Beginning This Lesson

Complete Lesson 1: Using the Interface.

Access a wide range of free, informative resources - full video tutorials, PDF guides, project 
files, and demo clips - designed to help you become a top SolidWorks user. Visit

http://www.solidworks.com/tutorials.
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Review of Lesson 1: Using the Interface

The interface is how you interact with the computer in the following ways:

� Use windows to view files.

� Use the mouse to select buttons, menus, and model elements.

� Run programs — like SolidWorks mechanical design software.

� Find, open, and work with files.

� Create, save, and copy files.

� SolidWorks runs on the Microsoft Windows graphical user interface.

� The mouse lets you move around the interface.

� The quickest way to open a file is to double-click on it.

� Saving a file preserves the changes that you have made to it.

� SolidWorks windows display graphic and non-graphic model data.

� CommandManager tabs display frequently used commands.
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Outline of Lesson 2 

� In Class Discussion — The SolidWorks Model

� Active Learning Exercise — Creating a Basic Part

• Create a New Part Document

• Overview of the SolidWorks Window

• Sketch a Rectangle

• Add Dimensions

• Changing the Dimension Values

• Extrude the Base Feature

• View Display

• Save the Part

• Round the Corners of the Part

• Hollow Out the Part

• Extruded Cut Feature

• Open a Sketch

• Sketch the Circle

• Dimension the Circle

• Extrude the Sketch

• Rotate the View

• Save the Part

� In Class Discussion — Describing the Base Feature

� Exercises and Projects — Designing a Switch Plate

� More to Explore — Modifying a Part

� Lesson Summary

Competencies for Lesson 2 

Students develop the following competencies in this lesson:

� Engineering: Develop a 3D part based on a selected plane, dimensions, and features. 
Apply the design process to develop the box or switch plate out of cardboard or other 
material. Develop manual sketching techniques by drawing the switch plate.

� Technology: Apply a windows based graphical user interface.

� Math: Understand units of measurement, adding and subtracting material, 
perpendicularity, and the x-y-z coordinate system.
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In Class Discussion — The SolidWorks Model

SolidWorks is design automation software. In SolidWorks, you sketch ideas and 
experiment with different designs to create 3D models. SolidWorks is used by students, 
designers, engineers, and other professionals to produce simple and complex parts, 
assemblies, and drawings.

The SolidWorks model is made up of:

� Parts

� Assemblies

� Drawings

A part is a single 3D object made up of features. A part can become a component in an 
assembly, and it can be represented in 2D in a drawing. Examples of parts are bolt, pin, 
plate, and so on. The extension for a SolidWorks part file name is .SLDPRT. Features are 
the shapes and operations that construct the part. The Base feature is the first feature that 
is created.The Base feature is the foundation of the part.

An assembly is a document in which parts, features, and other assemblies (sub-
assemblies) are mated together. The parts and sub-assemblies exist in documents separate 
from the assembly. For example, in an assembly, a piston can be mated to other parts, such 
as a connecting rod or cylinder. This new assembly can then be used as a sub-assembly in 
an assembly of an engine. The extension for a SolidWorks assembly file name is 
.SLDASM.

A drawing is a 2D representation of a 3D part or assembly. The extension for a 
SolidWorks drawing file name is .SLDDRW.
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Active Learning Exercises — Creating a Basic Part

Use SolidWorks to create the box shown at the right. 

The step-by-step instructions are given below.

Create a New Part Document

1 Create a new part. Click 

New  on the Menu 
Bar.

The New SolidWorks 

Document dialog box 
appears.

2 Click the Tutorial tab.

3 Select the Part icon. 

4 Click OK. 

A new part document 
window appears.

Base Feature

The Base feature requires:

� Sketch plane – Front (default plane)

� Sketch profile – 2D Rectangle

� Feature type – Extruded boss feature

Open a Sketch

1 Click to select the Front plane in the FeatureManager design tree.

2 Open a 2D sketch. Click Sketch > Sketch .

Confirmation Corner

When many SolidWorks commands are active, a symbol or a set of symbols appears in the 
upper right corner of the graphics area. This area is called the Confirmation Corner.

Sketch Indicator

When a sketch is active, or open, a symbol appears in the confirmation corner 
that looks like the Sketch tool. It provides a visual reminder that you are active in 
a sketch. Clicking this symbol exits the sketch saving your changes. Clicking the 
red X exits the sketch discarding your changes.
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When other commands are active, the confirmation corner displays two 
symbols: a check mark and an X. The check mark executes the current 
command. The X cancels the command.

Overview of the SolidWorks Window

� A sketch origin appears in the center of the graphics area.

� Editing Sketch1 appears in the status bar at the bottom of the screen.

� Sketch1 appears in the FeatureManager design tree.

� The status bar shows the position of the pointer, or sketch tool, in relation to the sketch 
origin.

Sketch a Rectangle

1 Click Sketch > Corner Rectangle . 

2 Click the sketch origin to start the rectangle. 

3 Move the pointer up and to the right, to create a 
rectangle.

4 Click the mouse button again to complete the 
rectangle.

Status bar

Graphics area

Sketch origin

Menu bar

FeatureManager design tree

Confirmation Corner with sketch indicator

Reference Triad

CommandManager

Heads-up View Toolbar
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Add Dimensions

1 Click Sketch > Smart Dimension . 

The pointer shape changes to .

2 Click the top line of the rectangle.

3 Click the dimension text location above the top line.

The Modify dialog box is displayed.

4 Enter 100. Click  or press Enter.

5 Click the right edge of the rectangle.

6 Click the dimension text location. Enter 65. Click .

The top segment and the remaining vertices are 
displayed in black. The status bar in the lower-right 
corner of the window indicates that the sketch is fully 
defined.

Changing the Dimension Values

The new dimensions for the box are 100mm x 60mm. Change the dimensions.

1 Double-click 65. 

The Modify dialog box appears.

2 Enter 60 in the Modify dialog box. 

3 Click .

Extrude the Base Feature.

The first feature in any part is called the Base Feature. In this exercise, the base feature is 
created by extruding the sketched rectangle.

1 Click Features > Extruded Boss/Base 

The Boss-Extrude PropertyManager appears. The view of the 
sketch changes to trimetric.
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2 Preview graphics.

A preview of the feature is shown at the default 
depth.

Handles  appear that can be used to drag the 
preview to the desired depth. The handles are 
colored magenta for the active direction and gray 
for inactive direction. A callout shows the current 
depth value.

The cursor changes to . If you want to create the 
feature now, click the right mouse button. Otherwise, you can make additional changes 
to the settings. For example, the depth of extrusion can be changed by dragging the 
dynamic handle with the mouse or by setting a value in the PropertyManager.

3 Extrude feature settings.

Change the settings as shown.

• End Condition = Blind

•  (Depth) = 50

4 Create the extrusion. Click OK .

The new feature, Boss-Extrude1, is displayed in the 
FeatureManager design tree.

TIP:

The OK button  on the PropertyManager is just one 
way to complete the command.

A second method is the set of OK/Cancel 
buttons in the confirmation corner of the 
graphics area.

A third method is the right-mouse 
shortcut menu that includes OK, 
among other options.

Sketch

Preview

Handle

On-screen Scale
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5 Click the plus sign  beside Boss-Extrude1 in 
the FeatureManager design tree. Notice that 
Sketch1 — which you used to extrude the feature 
— is now listed under the feature.

View Display

Change the display mode. Click Display Style > 
Hidden Lines Visible  on the Heads-up View 
toolbar.

Hidden Lines Visible enables you to select hidden back 
edges of the box.

Save the Part

1 Click Save  on the Menu Bar, or click File, Save.

The Save As dialog box appears.

2 Type box for the filename. Click Save.

The .sldprt extension is added to the filename.

The file is saved to the current directory. You can use the Windows browse button to 
change to a different directory.

Round the Corners of the Part

Round the four corner edges of the box. All rounds have the same 
radius (10mm). Create them as a single feature. 

1 Click Features > Fillet .

The Fillet PropertyManager appears.

2 Enter 10 for the Radius.

3 Select Full preview.

Leave the remaining settings at their default values.

Click Here
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4 Click the first corner edge.

The faces, edges, and vertices are highlighted as you 
move the pointer over them.

When you select the edge, a callout  
appears.

5 Identify selectable objects. Notice how the pointer 
changes shapes:

Edge:  Face:  Vertex: 

6 Click the second, third and fourth corner edges.

7 Click OK .

Fillet1 appears in the FeatureManager design tree.

8 Click Display Style > Shaded  on the Heads-up View 
toolbar.

Hollow Out the Part

Remove the top face using the Shell feature.

1 Click Features > Shell .

The Shell PropertyManager appears.

2 Enter 5 for Thickness.

Note: Normally, a callout only appears on 
the first edge you select. This 
illustration has been modified to 
show callouts on each of the four 
selected edges. This was done 
simply to better illustrate which 
edges you are supposed to select.
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3 Click the top face.

4 Click .

Extruded Cut Feature

The Extruded Cut feature removes material. To make an extruded cut requires a:

� Sketch plane – In this exercise, the face on the right-hand side of the part.

� Sketch profile – 2D circle

Open a Sketch

1 To select the sketch plane, click the right-
hand face of the box. 

2 Click View Orientation > Right  on the 
Heads-up View toolbar.

The view of the box turns. The selected 
model face is facing you.

3 Open a 2D sketch. Click Sketch > Sketch 
.

Top Face

Pick this face
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Sketch the Circle

1 Click Sketch > Circle .

2 Position the pointer where you want the center of the 
circle. Click the left mouse button.

3 Drag the pointer to sketch a circle.

4 Click the left mouse button again to complete the circle.

Dimension the Circle

Dimension the circle to determine its size and location.

1 Click Sketch > Smart Dimension . 

2 Dimension the diameter. Click on the circumference 
of the circle. Click a location for the dimension text 
in the upper right corner. Enter 10.

3 Create a horizontal dimension. Click the 
circumference of the circle. Click the left most 
vertical edge. Click a location for the dimension text 
below the bottom horizontal line. Enter 25.

4 Create a vertical dimension. Click the circumference 
of the circle. Click the bottom most horizontal edge. 
Click a location for the dimension text to the right of 
the sketch. Enter 40.

Extrude the Sketch

1 Click Features > Extruded Cut .

The Extrude PropertyManager appears.

2 Select Through All for the end condition.

3 Click .
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4 Results.

The cut feature is displayed.

Rotate the View

Rotate the view in the graphics area to display the model from different angles.

1 Rotate the part in the graphics area. Press and hold the middle mouse button. Drag the 
pointer up/down or left/right. The view rotates dynamically.

2 Click View Orientation > Isometric  on the Heads-up View toolbar. 

Save the Part

1 Click Save  on the Menu Bar.

2 Click File, Exit.
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Lesson 2 — 5 Minute Assessment — Answer Key

Name: _______________________________Class: _________ Date:_______________

Directions: Answer each question by writing the correct answer or answers in the space 

provided or circle the answer as directed.

1 How do you start a SolidWorks session?

Answer: Click . Click All Programs. Click the SolidWorks folder. Click the 
SolidWorks application.

2 Why do you create and use Document Templates?

Answer: Document Templates contain the units, grid and text settings for the model. 
You can create Metric and English templates each with different settings.

3 How do you start a new Part Document? 

Answer: Click the New icon. Select a part template.

4 What features did you use to create the box? 

Answer: Extruded Boss, Fillet, Shell, and Extruded Cut.

5 True or False. SolidWorks is used by designers and engineers. 

Answer: True.

6 A SolidWorks 3D model consists of _________ _________ ________.

Answer: Parts, assemblies and drawings. 

7 How do you open a sketch? 

Answer: Click the Sketch icon on the Sketch CommandManager tab.

8 What does the Fillet feature do?

Answer: The Fillet feature rounds sharp edges.

9 What does the Shell feature do?

Answer: The Shell feature removes material from the selected face.

10 What does the Cut-Extrude feature do? 

Answer: The Cut-Extrude feature removes material.

11 How do you change a dimension value? 

Answer: Double-click on the dimension. Enter the new value in the Modify dialog box.
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Lesson 2 — 5 Minute Assessment REPRODUCIBLE

Name: _______________________________Class: _________ Date:_______________

Directions: Answer each question by writing the correct answer or answers in the space 

provided or circle the answer as directed.

1 How do you start a SolidWorks session?

_____________________________________________________________________

_____________________________________________________________________

2 Why do you create and use Document Templates?

_____________________________________________________________________

_____________________________________________________________________

3 How do you start a new Part Document? 

_____________________________________________________________________

4 What features did you use to create the box? 

_____________________________________________________________________

5 True or False. SolidWorks is used by designers and engineers. 

_____________________________________________________________________

6 A SolidWorks 3D model consists of _________ _________ ________.

_____________________________________________________________________

7 How do you open a sketch? 

_____________________________________________________________________

8 What does the Fillet feature do?

_____________________________________________________________________

9 What does the Shell feature do?

_____________________________________________________________________

10 What does the Cut-Extrude feature do? 

_____________________________________________________________________

11 How do you change a dimension value? 

_____________________________________________________________________
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In Class Discussion — Describing the Base Feature

Pick up a pencil. Ask the students to describe the base feature of the pencil. How would 
you create the additional features for the pencil?

Answer

� Sketch a circular 2D profile.

� Extrude the 2D sketch. This creates the base 
feature which is named Extrude1. 

� Select one circular edge on the base feature. 
Create a fillet feature. The fillet feature 
removes sharp edges. The fillet feature creates 
the eraser for the pencil.

� Select the other circular edge on the base 
feature. Create a chamfer feature. The chamfer 
feature creates the point for the pencil.

Exercises and Projects — Designing a Switch Plate

Switch plates are required for safety. They cover live electrical wires and protect people 
from electric shock. Switch plates are found in every home and school.

Caution: Do not use metal rulers near switch plates attached to a live wall outlet.

Tasks

1 Measure a single light plate switch cover.

Answer: Overall a single switch plate is 
approximately 70mm x 115mm x 10mm. The 
switch cut-out is approximately 10mm x 25mm.

2 Using paper and pencil, manually sketch the 
light plate switch cover.

3 Label the dimensions.

4 What is the base feature for the light plate 
switch cover?

Answer: It is an extruded boss feature.

Fillet Feature

Base Feature

Chamfer Feature
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5 Create a simple single light switch cover 
using SolidWorks. The filename for the part 
is switchplate.

6 What features are used to develop the 
switchplate?

Answer: The extruded boss, chamfer, shell 
and extruded cut features are used to create 
the switchplate.

• The order in which the features are 
created is important.

First – create the base feature.

Second – create the chamfer feature.

Third – create the shell feature.

Fourth – create the cut feature for the switch hole.

Fifth – create the cut feature for the screw holes.

• The file switchplate.sldprt is found in Lessons\Lesson2 in the 
SolidWorks Teacher Tools folder.

7 Create a simplified duplex outlet cover 
plate. The filename for the part is 
outletplate.

Answer: The outletplate.sldprt 
file is found in Lessons\Lesson2 in the 
SolidWorks Teacher Tools folder.

8 Save the parts. They will be used in later 
lessons.
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More to Explore — Modifying a Part

Many pencils have a longer, sharper point than the one shown earlier. How can this be 
accomplished?

Answer

Answers will vary. One possibility is:

� Double-click chamfer feature, either in the 
FeatureManager design tree or the graphics area.

� Change the angle to 10°.

� Change the distance to 25mm.

� Click Rebuild  on the Menu Bar to rebuild 
the part.

Another possibility is:

� Edit the definition of the chamfer feature.

� Change the Type option to Distance-Distance.

� Set the Distance1 value to 25mm.

� Set the Distance2 value to 4.5mm.

� Click OK to rebuild the chamfer feature.
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Lesson 2 Vocabulary Worksheet — Answer Key

Name: _______________________________Class: _________ Date:_______________

Fill in the blanks with the words that are defined by the clues.

1 The corner or point where edges meet: vertex

2 The intersection of the three default reference planes: origin

3 A feature used to round off sharp corners: fillet

4 The three types of documents that make up a SolidWorks model: parts, assemblies, 

drawings

5 A feature used to hollow out a part: shell

6 Controls the units, grid, text, and other settings of the document: template

7 Forms the basis of all extruded features: sketch

8 Two lines that are at right angles (90°) to each other are: perpendicular

9 The first feature in a part is called the base feature.

10 The outside surface or skin of a part: face

11 A mechanical design automation software application: SolidWorks

12 The boundary of a face: edge

13 Two straight lines that are always the same distance apart are: parallel

14 Two circles or arcs that share the same center are: concentric

15 The shapes and operations that are the building blocks of a part: features

16 A feature that adds material to a part: boss

17 A feature that removes material from a part: cut

18 An implied centerline that runs through the center of every cylindrical feature: axis
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Lesson 2 Vocabulary Worksheet REPRODUCIBLE

Name: _______________________________Class: _________ Date:_______________

Fill in the blanks with the words that are defined by the clues.

1 The corner or point where edges meet: ______________________________________

2 The intersection of the three default reference planes:___________________________

3 A feature used to round off sharp corners: ____________________________________

4 The three types of documents that make up a SolidWorks model: _________________

5 A feature used to hollow out a part: _________________________________________

6 Controls the units, grid, text, and other settings of the document:__________________

7 Forms the basis of all extruded features: _____________________________________

8 Two lines that are at right angles (90°) to each other are: ________________________

9 The first feature in a part is called the ____________ feature.

10 The outside surface or skin of a part: ________________________________________

11 A mechanical design automation software application:__________________________

12 The boundary of a face: __________________________________________________

13 Two straight lines that are always the same distance apart are: ____________________

14 Two circles or arcs that share the same center are:______________________________

15 The shapes and operations that are the building blocks of a part: __________________

16 A feature that adds material to a part: _______________________________________

17 A feature that removes material from a part: __________________________________

18 An implied centerline that runs through the center of every cylindrical feature:_______
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Lesson 2 Quiz — Answer Key

Name: _______________________________Class: _________ Date:_______________

Directions: Answer each question by writing the correct answer or answers in the space 

provided or circle the answer as directed.

1 You build parts from features. What are features?

Answer: Features are the shapes (bosses, cuts and holes) and the operations (fillets, 
chamfers and shells) that are use to build a part.

2 Name the features that are used to create the box in Lesson 2.

Answer: Extruded Boss, Fillet, Shell and Extruded Cut.

3 How do you begin a new part document? 

Answer: Click the New tool or click File, New. Select a part template.

4 Give two examples of shape features that require a sketched profile. 

Answer: Shape features are Extruded Boss, Extruded Cut, and Hole. 

5 Give two examples of operation features that require a selected edge or face.

Answer: Operation features are Fillet, Chamfer and Shell.

6 Name the three documents that make up a SolidWorks model.

Answer: Parts, assemblies and drawings

7 What is the default sketch plane? 

Answer: The default sketch plane is Front.

8 What is a plane? 

Answer: A plane is a flat 2D surface.

9 How do you create an extruded boss feature?

Answer: Select a sketch plane. Open a new sketch. Sketch the profile. Extrude the 
profile perpendicular to the sketch plane.

10 Why do you create and use document templates?

Answer: Document templates contain the units, grid and text settings for the model. 
You can create Metric and English templates, each with different settings.
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Lesson 2 Quiz REPRODUCIBLE

Name: _______________________________Class: _________ Date:_______________

Directions: Answer each question by writing the correct answer or answers in the space 

provided or circle the answer as directed.

1 You build parts from features. What are features? ______________________________

_____________________________________________________________________

2 Name the features that are used to create the box in Lesson 2.____________________

_____________________________________________________________________

3 How do you begin a new part document? ____________________________________

_____________________________________________________________________

4 Give two examples of shape features that require a sketched profile. _______________

_____________________________________________________________________

5 Give two examples of operation features that require a selected edge or face. ________

_____________________________________________________________________

6 Name the three documents that make up a SolidWorks model. ____________________

_____________________________________________________________________

7 What is the default sketch plane?___________________________________________

_____________________________________________________________________

8 What is a plane? ________________________________________________________

_____________________________________________________________________

9 How do you create an extruded boss feature? _________________________________

_____________________________________________________________________

10 Why do you create and use document templates? ______________________________

_____________________________________________________________________
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Lesson Summary

� SolidWorks is design automation software.

� The SolidWorks model is made up of:

Parts

Assemblies

Drawings

� Features are the building blocks of a part.
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Thumbnail Images of PowerPoint Slides

The following thumbnail images, arranged left to right, show the PowerPoint slides 
provided with this lesson.
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What is SolidWorks?

Simulate

Publish

Design

Manage

Sustain

Intuitive solutions for every stage of your design.
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SolidWorks – For Everything You Design
Consumer

High-
Tech

Energy

Construction

Automotive

Industrial
Equipment

Life Sciences

Shipbuilding

Aerospace Consumer
Packaged

Goods

Business
Services 4
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The SolidWorks Model

� The SolidWorks model is made up of:

� Parts

� Assemblies

� Drawings
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Part Part

AssemblyDrawing Drawing

The SolidWorks Model
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Features

� Features are the
building  blocks of the 
part.

� Features are 
the shapes 
and operations 
that construct 
the part.
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Examples of Shape Features

� Base Feature
� First feature 

in part.
� Created from 

a 2D sketch.
� Forms the 

work piece to 
which other 
features are 
added.
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Examples of Shape Features

� Boss feature
� Adds material 

to part.
� Created from 

2D sketch.
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Examples of Shape Features

� Cut feature
� Removes 

material from 
part.

� Created from 
2D sketch.
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Examples of Shape Features

� Hole feature
� Removes 

material.
� Works like 

more 
intelligent 
cut feature.

� Corresponds 
to process 
such as 
counter-sink, 
thread, counter-
bore.
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Examples of Shape Features

� Fillet feature
� Used to round off 

sharp edges.
� Can remove or add 

material.
� Outside edge 

(convex fillet) 
removes 
material.

� Inside edge 
(concave fillet) 
adds material.
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Examples of Shape Features

� Chamfer  feature
� Similar to a fillet.
� Bevels an 

edge rather 
than rounding it.

� Can remove or 
add material.
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Sketched Features & Operation Features

� Sketched Features
� Shape features have sketches.
� Sketched features are built from 2D profiles.

� Operation Features
� Operation features do not have sketches.
� Applied directly to the work piece by selecting edges or faces.
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Sketch the 2D profile

To Create an Extruded Base Feature:

1. Select a sketch plane.

2. Sketch a 2D profile.

3. Extrude the sketch 
perpendicular to 
sketch plane.

Select the sketch plane

Extrude the sketch Resulting base feature

15

�©
 D

as
sa

ult
 S

ys
tèm

es
 �C

on
fid

en
tia

lI
nfo

rm
ati

on
 �

To Create a Revolved Base Feature:

1. Select a sketch plane.
2. Sketch a 2D profile.
3. Sketch a centerline (optional).
4. Revolve the sketch around

a sketch line or centerline.

Centerline (optional)
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Terminology: Document Window

� Divided into two panels:
� Left panel contains 

the FeatureManager® 
design tree.
� Lists the structure of 

the part, assembly or 
drawing.

� Right panel contains 
the Graphics Area.
� Location to display, 

create, and modify 
a part, assembly or 
drawing.

FeatureManager 
design tree

Graphics Area
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Terminology: User Interface

Menu
Bar

Task pane

Status bar

Command
Manager

Drawing
document
window

Part
document
window
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Terminology: PropertyManager

Property
Manager

Confirmation
corner

Preview

Handle
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Terminology: Basic Geometry

� Axis - An implied centerline that runs 
through every cylindrical feature.

� Plane - A flat 2D surface.
� Origin - The point where the three 

default reference planes intersect. The 
coordinates of the origin are:

(x = 0, y = 0, z = 0).

Axis
Plane

Origin
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Terminology: Basic Geometry

� Face           �
The surface or �skin�  of a part. Faces 
can  be flat or curved.

� Edge           �
The boundary of  a face. Edges can 
be straight or curved.

� Vertex           �
The corner where edges meet.

Vertex

Edge

Edge

Faces
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Features and Commands

Base feature
� The Base feature is the first feature that is created.
� The Base feature is the foundation of the part.
� The Base feature geometry for the box is an extrusion.
� The extrusion is named Extrude1.
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Features and Commands

Features used to build the box are:
� Extruded Base feature
� Fillet feature
� Shell feature
� Extruded Cut feature

1.Base Feature 2.Fillet Feature

3.Shell Feature 4.Cut Feature
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Features and Commands

To create the extruded base feature for the box:
� Sketch a rectangular profile on a 2D plane.
� Extrude the sketch.
� By default extrusions are perpendicular to 

the sketch plane.
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Features and Commands

Fillet feature
� The fillet feature rounds the edges or 

faces of a part.
� Select the edges to be rounded. 

Selecting a face rounds all the edges 
of that face.

� Specify the fillet radius.

Fillet
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Features and Commands

Shell feature
� The shell feature removes material from 

the selected face.
� Using the shell feature creates a hollow 

box from a solid box.
� Specify the wall thickness

for the shell feature.

Wall Thickness

26

�©
 D

as
sa

ult
 S

ys
tèm

es
 �C

on
fid

en
tia

lI
nfo

rm
ati

on
 �

Features and Commands

To create the extruded cut 
feature for the box:
� Sketch the 2D circular profile.
� Extrude the 2D Sketch profile 

perpendicular to the sketch 
plane.

� Enter Through All for the end 
condition.

� The cut penetrates through 
the entire part.
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Dimensions and Geometric Relationships

� Specify dimensions and geometric relationships between features and 
sketches.

� Dimensions change the size and shape of the part.
� Mathematical relationships between dimensions can be controlled by 

equations.
� Geometric relationships are the rules that 

control the behavior of sketch geometry.
� Geometric relationships help capture design 

intent.
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Dimensions

� Dimensions
� Base depth = 50 mm
� Boss depth = 25 mm

� Mathematical relationship
� Boss depth = Base depth ÷ 2

29

�©
 D

as
sa

ult
 S

ys
tèm

es
 �

Co
nfi

de
nti

al
Inf

or
ma

tio
n 

�

Geometric Relationships

Tangent

Parallel

Horizontal
Vertical

Intersection

Concentric Perpendicular
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The SolidWorks Window
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Creating New Files Using Templates

� Click New         on the Menu Bar.
� Select a document template:

� Part
� Assembly
� Drawing

Tutorial Tab
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Document Templates

� Document Templates control the units, grid, text, and other 
settings for the model.

� The Tutorial document templates are required to complete the 
exercises in the Online Tutorials.

� The templates are located in the Tutorial tab on the New 
SolidWorks Document dialog box.

� Document properties are saved in templates.
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Document Properties

� Accessed through 
the Tools, Options 
menu.

� Control settings like:
� Units: English (inches) 

or Metric (millimeters)
� Grid/Snap Settings
� Colors, Material 

Properties and Image 
Quality
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System Options

� Accessed through 
the Tools, Options 
menu.

� Allow you to 
customize your work 
environment.

� System options 
control:

� File locations
� Performance
� Spin box increments

35

�©
 D

as
sa

ult
 S

ys
tèm

es
 �

Co
nfi

de
nti

al
Inf

or
ma

tio
n 

�

Multiple Views of a Document

� Click the view  pop-up menu.
� Select an icon. The viewport  icons include:

� Single View
� Two View 

(horizontal and 
vertical)

� Four View
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Creating a 2D Sketch

1. Click Sketch > Sketch      .

2. Select the Front 
plane as a sketch 
plane.

3. Click Sketch >
Rectangle       .

4. Move the pointer to 
the Sketch Origin.
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Creating a 2D Sketch

5. Click the left mouse button.

6. Drag the pointer 
up and to the right.

7. Click the left 
mouse button 
again.
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Adding Dimensions

� Dimensions specify the size of the model.

To create a dimension:

1. Click Sketch > Smart Dimension       .

2. Click the 2D geometry.

3. Click the text location.

4. Enter the dimension value.

2D geometry

Text location


