QUICK START CablEquity™

Design Flow Highlights

Components Selection

turboConfigurator

Output Documentation

Special Functionality

Library

Control System Schematic Capture

Transfer 3D Models

Export and Import designs (Important during updating CablEquity™)
Backup and Restore databases

User DB Utility (Export and Import Components during updating CablEquity™)
Functionalities

Components Selection

A. Browsing database
1. Go to the Gallery on the menu bar

|ﬁ TurboTools Corporation - CablEquity
File @ Gallery  Location DRC  MCAD Setup  Sysktem Setup Help

2. Select Category, from the pull-down menu by left mouse click
Gallery | Location DRC  MCE

Conneckars

Backshels

Cable Materials

Disconnecks

Splices

Terminal Blocks

Terminals

Miscelanies

Conneckar Accessaries

Conneckor Hardware

RENBEHNE TR NED

Conkacks

3. Select Type, by left mouse click on the Type picture on the main pane
4. Select component part number, by left mouse click on the lower pane
5. Select as many components as you want side-by-side
B. Setup Project
1. Setup Product
a. Click on the Products tab, than right mouse click on the Products
on the tree to open the Menu. Click on the New => Product on the
menu to open the “New Product” dialog box.
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b. Enter all info on dialog box and click OK. New product will appear

on the Products tree immediately.
2. Setup Project

a. Click on the Projects tab, than right mouse click on the Projects on
the tree to open the Menu. Click on the New => Project/Assembly
on the menu to open the “"New Project/Assembly” dialog box.

b. Enter all info on dialog box and assign new project to the
previously created product, than click OK. New project will appear
on the Projects tree immediately.

3. Setup Design

a. Right mouse click on the new created project to open the Menu.
Click on the New => Design on the menu to open the “"New
Design” dialog box.

b. Enter all info on dialog box than click OK. New design with
automatically created Rev.1 will appear on the tree under the new
project immediately.

C. Design Wizard
1. Right mouse click on the revision to open the Menu, and than Design
Wizard
2. First screen “Models” will open. Select humber of Sources and
Destinations required for the design by clicking @ O
Click button “Next” to continue design wizard
Second screen “Locations” will open
a. Left mouse click on the Source 1 location on the upper part of the
screen, all controls on the lower part of the screen will appear
b. Selection connector for this location can be done manually, by the
netfile, or by the MFG/IPN part number
i. Manual

1st) Left mouse click on the desire location

2nd) Click on the button “Manual”

3rd) Select radio-button “Terminated”

4th) From “Gender” pull-down select contacts gender

5th) Select “Contact Qty”

6th) Optionally, type-in Ref Des/Alias

7th) Click button “Next” to continue design wizard

ii. Netfile

1st) Left mouse click on the desire location

2nd) Click on the button “Netfile”

W
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3rd) On the “"SMART File Importer” screen select netfile
format from the CAD application where it was created
and click OK

&) CablEquity - SMART File Importer
File
From Schematic Capkure  » QrCaDiCadence)
From PCE Lawouk » acceldalkionm)
Praokel{Alkium)
MMenkar
P-CAD{Alkum)
PADSMentor)
Wiewlogic/ InnovedalMentor )-MNet
WeriBest{Mentar)
Wiewlogic) Innoveda(Menkor)-Sch

4th) Navigate to the location of the file on the proper drive
and click Open
5th) Select Reference designator for the connector from
the netfile and click OK
6th) All info from the netfile automatically loads onto
“Locations” screen
7th) Click button “Next” to continue design wizard
iii. Part#
1st) Left mouse click on the desire location
2nd) Click on the button “Manual”
3rd) Select radio-button “Terminated”
4th) Left mouse click on the text box “MFG/IPN”
5th) Type-in part number, for example 205841-2
6th) Click button “Part#"”
7th) Text box "MFG/IPN” becomes gray-out; text boxes
“Gender”, “Ref Des/Alias” for Ref Des, and “Contact
Qty” automatically filled-in with necessary data
8th) Click button “Next” to continue design wizard
c. After connector (termination, gender, and contacts quantity)
selected, alias designator can be assign, than click Next
5. Third screen “Categories” will open
a. Click on the Connectors picture
b. Click button “Next” to continue design wizard
6. Forth screen “"Connectors” will open
a. Click on the Type connector picture
b. Click button “Next” to continue design wizard
7. Fifth screen "Component Specifics” opens
a. Expend component’s tree with the proper branch to the required
level
b. Highlight desired node
c. Click button “"Next” to continue design wizard
8. Sixth screen “Component Part Number” opens
a. Make component selection by Manufacturer, Attributes or Part
Number

Copyright © 2011 TurboTools™ Corporation
January, 2011 A_Design Flow Highlights - QUICK START-2.2.5.doc
English: rev.2.2.5
page 3 of 22



QUICK START CablEquity™

b. Select Quantity if required
c. Click button “Save” to continue design wizard
9. Seventh screen “Internal Part Number” opens
a. Component will be listed only it does not have IPN
b. To enter IPN, click on the listed component and type-in IPN in the
pop-up text box. To finish entering IPN click outside pop-up text
box
c. Click button “"Next” to continue design wizard
d. If IPN is not available at this point, skip steps a, b, c and click
button “Next” to continue design wizard
10. Eighth screen “Required Components” opens
a. By checking appropriate check box next to the required
components, make selection of the component, using the same
sequence
b. After all components selected (by designer decision), check box
“Location Completed”
c. Click button “Continue” to continue design wizard
11.Second screen “Locations” will open
a. Continue components selection for all locations
b. The last location to be completed is Cable Material. After it is
completed successful completion components selection message
will appear
12. Next step in design process is turboCnfigurator

turboConfigurator

A. turboConfigurator screen
1. Right mouse click on the revision to open the Menu, and than
turboConfigurator to open the screen

‘Eﬂ Mt r

Qpen

e

Edit r

.
/

Design Wizard

+
+

turboConFigurator
Bill F Materials
Assembly Draving
Schematic

a0 Transfer »

Erng. Release

kB e @O

Diata r

ol

Exit
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B. Sketcher
1. Following picture shows default sketcher mode for the 1Sx2D cable
model

Configuration Sketcher I

2. To make connection between source, destination and central segments
do following:

a. Click left mouse on the S01 segment, segment will highlighted and
green handles will appear. Position the pointer over the S01
segment. When the pointer changes to a four-headed arrow, hold
down the mouse button and drag S01 segment to the central
segment until they glued together

b. Do the same with other source and destination segments

Configuration Sketcher I

c. After configuration of the cable assembly completed, click Set
radio-button on Dimension panel
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Configuration Sketcher I

d. There are two pictures of the wrong placement of D2, D3 and D4

D02 J9

Lirya
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e. There is a picture of the right placement of D2, D3 and D4

=01; FT

C. Dimensions

1L Finf]

1. From the pull-down Unit select proper dimension units

nhwnN

January, 2011

English: rev.2.2.5

Dimensions
f+ Set " Hide = Show

" Reset
Segment [t
Doz
C T alerance
| .
Segmert | Length | Tale... | LI rit
0m 10 1 Inch

Select segment that needs to be assigned with dimension
Enter length and tolerance

Click button Add

Assign all segments with dimensions
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6. When all segments are done, Proportional Layout drawing generates
automatically on the Sketcher panel

7. To delete any previously entered segment’s length, double-click on the
corresponded segment on the Dimensions panel

8. To re-enter length for the segment, open Segment pull-down menu
and enter length again

D. Miscellaneous
1. Miscellaneous for the cable/harness assembly can be selected from the

miscellaneous legend

Miscellaneous
" Hide 1 Show

[ Show Segment MNames

Type | D'escription

[ | Core Ferrite

Tie wrap

“Wwire Clamp
Tubing - Cables
Sleeving
Jacket

Shield

Spiral Wrap
Splice

SHEEee

Part Murnber | Placed | Leh... | i

2. To select any miscellaneous, click on the desire type and select the
segment where component should be installed
3. Enter all required info to proceed with selection
E. Continuity
1. Continuity is the functionality where all electrical connections between
locations can be entered and stored. There is a view of the continuity

panel
Signals available: 1 Connects Locahons: P10; P11; P12; Signals available: 3
|Source 1:F10 | [1.1: Part #3212; Multiconductor, Braid Shield Cable ~|  |Destination P12 |
Source 1:P10
To. | 5l i Camatelia Col Destination 1:P11
1 2 | |§_jn§ | Lty | o i Destination 2.P12
[M!ss!ng] u1 2 Bla_c:k C Segment:Splice 1;
2 [Miszing] =1 4 Shield C Segment Splice 2:
3 [Missing] C Segment:Splice 3;
< >

Frarm: Contacti:on:RefDes Signal To: Contactth:on:RefDes Colar Code

1: Source 1:P10 Signal 1 1: Degtination 1:P11 Conductor # 1: Color: White

2 Source 1:P10 Signal 2 3 Degtination 1:P11 Conductor # 2: Color: Red
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2. To enter electrical connection do following:
a. From the pull-down menu “Select Cable Material” select a cable
b. From the left pull-down menu select Source location
c. From the right pull-down menu select Destination location
d. Select contact on the source, conductor on the cable material, and
contact on the destination - popup with signal name request will

appear
Signals available: 1 Connects Locations: P10; P11; P12; Signals available: 3
|Source 1:F10 | [1.1: Part #3212; Multicanductor, Braid Shield Cable | |Destination 2:P12 |
Ca... | Signal | k... | Conductar # Calor Can.. | Sighal | k... |
1 [Mizzing] w1 2 Black. 1 [Mizzing]
2 hizzi 1 2 b iz
3 {M:zz::g} # ;—:nter Signal Name or Select the correct one| 3 {M :zz::g}
Signal [Signal |
< ¥
From: Contacti:on:RefDes Signal To: Contacti:onRefDies Color Code
1: Source 1:P10 Signal 1 1: Destination 1:P11 Conductor # 1: Color; White
2 Source 1:P10 Signal 2 3 Destination 1:P11 Conductor # 3: Color; Red

e. Type-in signal name, and click outside the popup box
f. Make electrical connections between all necessary locations’
contacts
F. Complete turboConfigurator
1. Go to File and select Save

turboConfigurator: Cable w/splices, Rey 3

File | Edit  Wiew Help
&l save
Complete 5
Hide @+ Show
Exit
! S

Then Complete

Close turboConfigurator

Those completes revision, and changes revision status to “"Completed”
CablEquity is ready to generate output documentation

uhwn

Output Documentation

A. Assembly Drawing
1. Right mouse click on the revision to open the Menu, and than ASSY
Drawing to open the “Drawing Info” dialog box
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CablEquity™

2. On “Drawing Info” dialog box company profile can be entered and than

selected

a. From pull-down “Company” select company name (profile)
b. To create company profile, from pull-down Company, select <New

Company>

L. Drawing Info

=,

Mane:

Design Mame:

izeneral ].ﬁ.dditiunal Info ] Cuskam ]

Revision 2

Cable wisplices

COmpany':

Mote & |
Nate 1 |

<Mew Company =

Afikirn Electric Mobilizers Lkd
APPLIED MATERIALS, IMC,
BROOES AUTOMATION, INC,
Critical Telecon Corporation

DIMEMSIONS,

MEASUREMENT DA C Inkernational

DAC Inkernational Inc,
DATAPATH, INC.

[ ) |l

Title Block,

Draw

Cancel
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c. "Company Info” dialog box opens. Enter all appropriate info for
the company profile

s S

%k Company Info

Marme:

Skreat:

ity

State:

Ehone;

E-Mail:

Wehsite:

|
|
|
|
Zip! |
|
|
|

Propriekary
[rata

Logo: .

Ik Cancel

d. If State is not a US state, you can type Country name, City name
and State name in the “City” text box
e. If zip code longer then 5 characters, type it in the “City” text box
as well
f. Before assigning company logo please do following
i. Create company logo and save it in the BMP format, other
file formats will not accepted
ii. Copy company logo file into “"C:\Program
Files\CablEquity\Templates” folder
g. To assign company logo, click “*Logo” button and navigate to the
“C:\Program Files\CablEquity\Templates” folder
h. Highlight company logo file and click OK
i. If company logo is not selected, TurboTools logo will be assign
automatically
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j. After all selections completed, click OK, to return to the “Drawing
Info” dialog box

If needed enter additional info, use tabs “Additional Info” and
“Custom”
Click “Title Block” button to select appropriate title block format
Click “Draw” button to start generating assembly drawings
Next popup message asks if you would like to see drafting process, or
generate drawings silently

=,

CablEquity

1?/ Showe drafting process?

Yes Mo Cancel |

a. To be able speed up drafting process for a big designs always use
silent mode, by clicking “"No” button

B. Schematic

1.

2.

C. BOM

Right mouse click on the revision to open the Menu, and than
Schematic to generate schematic

Next popup message asks if you would like to see drafting process, or
generate schematic silently

Right mouse click on the revision to open the Menu, and than Bill of
Materials to open “"BOM Options” popup

(% BOM Options

Choose options For Revision 2 of Design;
" able wysplices"

(" Mo details with |locations
" Wiew details
" Wiew details with locakions

Cancel

2. Select BOM option by clicking on the appropriate radio-button, then OK

Special Functionality - Listing

mmoONwr>

January, 2011

English: rev.2.2.5

Changing Alias name

Editing ASSY Drawing or Schematic
Save ASSY Drawing or Schematic
Conversion ASSY Drawing or Schematic
Save BOM

Exporting BOM
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G. DRC
H. Location menu
I. Edit menu
J. Engineering Release menu
K. Archive
L. Search
Library

A. Use existing Libraries
1. CablEquity has extensive electrical, mechanical and other libraries

‘u CablEquity: Schematic
File Inmsert ‘iew Shape Help

[0-BE & dE-=2]q-@ls2 0o/ ~ve 9o
; -2 -1 (]

12 14 1

oo

Electrical » Analag and Digital

T Mechanical k Basic Ikems

Eleckromechanical * Composite Assemblies

15

Miscellaneous 4 Conkrol Circuits

VW EN

15

My Libraries Electrical Symbaols

14

Genetic Electrical Companents

IZ Components

13

Relays and Conkacks

12

Semiconductors and Electron Tubes

Sensors and Actuakors

11

Signals

10

Switches
Terminals and Connectors

o= Transformers and \Windings

2. Every drawing or schematic can be edited using libraries’ components
3. To bring shape from the library, open the library and then D&D shape
on the drawing
B. Create a new Library
1. New library can be created under My Libraries
2. To create a new library go to “File => New => New Library”
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= | CablEquity: Schematic

File | Insert  Wiew Shape Help

] Hew L4 Partrait L4 .i),
[ open Landscape  * m

Close ] rew Library

]

Save

Save fs

Expork g
Printer Setup

Page Setup

Print

=

(B9

Drawing Page Setup

Exit

3. D&D shape that should be stored in the library from the drawing

window into the library window

Type-in a proper name for the new shape

Right mouse click on the "New Library” tab in library window, and

select Save As

6. Type-in proper name for the new library

7. Navigate to the “C:\Program Files\CablEquity\Templates” folder and
click OK

vk

Control System Schematic Capture

A. Create a new document
B. Copy drawing from AutoCAD

Transfer 3D Models

A. Integration with 3D MCAD
B. Transfer models

Export and Import designs

1. Exporting existing Projects/Designs/Revisions
a. Run CablEquity
b. Highlight Project/Design/Revision by clicking left mouse
i. Make sure to “"Export” all new created components used in

exporting designs in order to import them together with designs
into the new database

c. Go to the “Export” button on the toolbar and left mouse click on it

d. Follow the instructions to export selected design into the XML file

e. Remember the folder where you exported selected design
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2.

Importing Projects/Designs/Revisions

a. Run CablEquity

b. Highlight the highest node on the Project Manager tree “Projects” in
order to import entire product or top level project. For the sub-project,
design or revision, please select proper level on the Project Manager
tree
Go to the “Import” button on the toolbar and left mouse click on it
Navigate to the folder where all exported/received designs are stored
in XML file format
e. Click on the XML file and follow the instructions to Import it into the

database

i. Make sure to “Import” all new created components used in
importing designs in order to use designs properly

Qo

Backup and Restore databases

Important! Restore any database is possible only after all databases are backup

Backup procedure:

Run CablEquity from the desktop. Before doing anything else, follow the steps
for the Backup procedure

2. Click on the “Backup Database” icon on the toolbar

3. Click on the “Projects/Designs” radio button

4. Click the “Backup to” button, and in the “Select the destination file to back
up” dialog box click “Save”. Default directory is
C:\TurboTools\CablEquity\Data Files\Backup\

5. When backup of “Projects” is completed, do the same for *"Components”

6. Click on the "Components” radio button

7. Click the “Backup to” button, and in the “Select the destination file to back
up” dialog box click “Save”. Default directory is
C:\TurboTools\CablEquity\Data Files\Backup\

8. When backup of "Components” is completed, do the same for "Documents”

9. Click on the “"Documents” radio button

10.Click the “Backup to” button, and in the “Select the destination file to back
up” dialog box click “Save"”. Default directory is
C:\TurboTools\CablEquity\Data Files\Backup\

11. When backup of "Documents” is completed, click the “Cancel” button

12."3D Components” is available only if “Integration with 3D MCAD"” package was
installed

13. Close CablEquity

Restore procedure:

1. In “C:\TurboTools\CablEquity\Data Files\Backup” directory manually rename
“Components.bak” to "Components-install.bak”, “Projects.bak” to “Projects-
install.bak”, and “Documents.bak” to "Documents-install.bak”

2. Copy or uncompress “Projects.zip”, and/or "Components.zip”, and/or
“"Documents.zip” into “C:\TurboTools\CablEquity\Data Files\Backup” directory
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Nowuhk

»—nuogo

11.
12.
13.

14.
15.

16.

Run CablEquity from the desktop. Before doing anything else, execute entire
Backup procedure

Click on the “"Restore Database” icon on the toolbar

Click “OK" to restore

Click on the “Components” radio button

Click the “Restore from” button, and in the “Select the source back up file to
restore” dialog box double-click on "Components.bak”

In the “Restore Database” dialog box click “"OK”

Click on the “Projects/Designs” radio button

.Click the “Restore from"” button, and in the “Select the source back up file to

restore” dialog box double-click on “Projects.bak”

In the “Restore Database” dialog box click “*OK”

Click on the “"Documents” radio button

Click the “Restore from” button, and in the “Select the source back up file to
restore” dialog box double-click on "Documents.bak”

In the “Restore Database” dialog box click “*OK”

“3D Components” is available only if “Integration with 3D MCAD"” package was
installed

After the restore is completed click “Cancel”, CablEquity will be closed
automatically

User DB Utility

General - Attributes

If Attribute has a definitive value (not a range), this value should be in the
“"FROM"” box. “"TO” box keep empty.

2. Value with decimal point should be in the following format “0.15” (*.15" is a
wrong format).

3. If Attributes have value "No”, do not enter it, unless it is absolutely necessary
for the search or DRC (Design Rule Checking).

4. For wire size in AWG, box "FROM” should have lower physical value (higher
numerical number) and box “TO” should have higher physical value (lower
numerical number).

General - Shapes

1. Use “Size & Position”, and all necessary tools from the toolbar

2. Use all necessary tools from the “"Shape” menu

3. All shapes should be designed in the 1:1 scale

4. All shapes should be designed in the left-top view

5. All sub-shapes must be highlighted and Grouped into one shape (go to Shape,
Grouping, Group)

Create NEW Connector in database
1. Open User DB Utility. "Connector types” is the default view.
2. Select the desired connector type by clicking on the appropriate picture.
Copyright © 2011 TurboTools™ Corporation
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3. On the pop-up screen select MFG and click on either “Edit/Create from
Existing” or “Create from Scratch” button.
4. Enter or edit an attribute’s information by clicking on it. Follow the
instructions on the subsequent pop-up screens.
5. For proper compatibility of newly added connectors with newly added
contacts, the following rules must apply:
a. The connector’s attribute “Class” value must match the contact’s
attribute “Connector Specific” value exactly
b. The connector’s attribute “Contact Size Accept” value must match the
contact’s attribute “Contact Size” value exactly
c. The connector’s attribute “Related Type 1” value must match the
contact’s attribute “Related Type 1" value exactly
6. On “Step 5” design and orient connector shape is similar to the connector in
this picture. Please notice:
a. All connectors should be designed on a 1:1 scale
b. All connectors from one FAMILY should have the same width, as
pictured in the “side view”
c. All connectors should be designed and oriented so that the front edge
is on the left, as pictured in the “side view”

Side View Wire View

LI

b 061
[@]

Front

2

{
i—d Rl

7. After the connector is created and saved, click on the “Linkage” (used to be
Drawing) tab.

8. The “Part Number” text box should display the part number of the newly
created connector, if it is not displayed, manually type it in. Click on “Fetch”
button to open the side view for the connector.

9. Type in the part humber of the contact that is associated with this connector
and click “Fetch.” If the contact has not been designed yet, steps 7 to 13
must be completed when the contact is available

a. For a connector with INTEGRATED contacts (one that does not require
contacts at all), please use any contact part number, for example
794606-1, to be able to create connection points

10. A message displaying: “Please select contacts on upper and lower boundaries,

and align left ends with the proper horizontal position” will appear. Click OK.
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11.2 contacts must be placed in their proper horizontal and vertical positions
with an acceptable distance between them. Please use your mouse and
keyboard to highlight contacts (click on a contact to highlight it; press and
hold the “Ctrl” key and click on each component to highlight multiple
components). Use your keyboard’s arrow keys for precise placement, then
click on the “Save” button.

a. This picture shows the alignment of contacts on a connector with
INSERTABLE contacts

b. This picture shows the alignment of contacts on a connector with
INTEGRATED contacts

12. A message displaying: “"Connection points have been added on Connector for
Contacts. Changes are saved.” will appear. Click OK.

13. A message displaying: “You can verify created connection points by activating
‘Connection Points’ menu under the ‘View’ menu. If any changes in creating or
placement connection points are needed you have to do this process again.”
will appear. Click OK.

Create NEW Contact in database

1. Open User DB Utility. “"Connector types” is the default view.
2. Select the "Contacts” category, and then select the desired contact type by
clicking on the appropriate picture.
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3. On the

CablEquity™

pop-up screen select MFG and click on either “Edit/Create from

Existing” or “Create from Scratch” button.

4. Enter or edit an attribute’s information by clicking on it. Follow the
instructions on the subsequent pop-up screens.

5. For proper compatibility of newly added connectors with newly added
contacts, the following rules must apply:

a.

The connector’s attribute “Class” value must match the contact’s
attribute “Connector Specific” value exactly

The connector’s attribute “Contact Size Accept” value must match the
contact’s attribute “Contact Size” value exactly

The connector’s attribute “Related Type 1” value must match the
contact’s attribute “Related Type 1" value exactly

6. On “Step 5":

a.

January, 2011
English: rev.2.2.5

From the toolbar, select Libraries => Miscellaneous => Tooling, to
open the Tooling library.

Select “"Pin” or "Socket” and drag and drop onto the page.

If the new contact requires a special shape, it must be designed and
oriented similar to the contact in this picture:

Contact Side View

]

]

[

After the shape of the contact is set, it must be sized proportionally to
the FAMILY of connectors with which it is meant to work. To do so
select Shape => Insert Reference from the toolbar. Enter the
connector part nhumber in the pop-up text box representing the FAMILY
of connectors that the newly created contact matches. Click OK.

Click on the contact shape. From the toolbar, select Shape => Order
=> Bring to Front, (the same commands are available from the right
mouse click menu) then position the contact shape over the connector
shape. Align the right edge of the contact with right edge of the
connector.

Re-size the contact to the proper size.

Click the Save button.
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Create NEW Backshell in database

1. Open User DB Utility. “"Connector types” is the default view.
2. Select the "Backshells” category, and then select the desired backshell type
by clicking on the appropriate picture.

3. On the

pop-up screen select MFG and click on either “Edit/Create from

Existing” or “Create from Scratch” button.

4. Enter or edit an attribute’s information by clicking on it. Follow the
instructions on the subsequent pop-up screens.

5. For compatibility of newly added backshells with newly added connectors, the
following rules must apply:

a.

g.

The connector’s attribute “Class” value must match the backshell’s
attribute “Connector Specific” value exactly

The connector’s attribute “"Contact Count” value must match the
backshell’s attribute “Housing Contact Count” value exactly

The connector’s attribute “Contacts Layout - # of Positions per Row”
value must match the backshell’s attribute “"Housing Layout - # of
Positions per Row” value exactly

The connector’s attribute “"Contacts Layout - # Rows” value must
match the backshell’s attribute "Housing Layout - # Rows” value
exactly

The connector’s attribute “"Housing Shell Size” value must match the
backshell’s attribute “Housing Shell Size” value exactly

Steps 'c’ and 'd’ together are interchangeable with step ‘e’ or vice
versa

The connector’s attribute “"Related Type 1” value must match the
backshell’s attribute “Related Type 1” value exactly

6. On "Step 5” design and orient backshell shape is similar to the backshell in
this picture. Please notice:

a.

January, 2011
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All backshells should be designed on a 1:1 scale
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All backshells from one FAMILY should have identical dimensions, as
pictured in the “side view”

All backshells should be designed and oriented so that the connector
engagement edge is on the left, as pictured in the “side view”

Side View

..--""'""-_#r )

Connector
engagement here

7. On “Step 5":

a.

d.

After the shape of the backshell is set, it must be sized proportionally
to the connector with which it will work. To do so select Shape =>
Insert Reference from the toolbar. Enter the connector part number in
the pop-up text box that the newly created backshell will match to.
Click OK.

Click on the backshell shape. From the toolbar, select Shape => Order
=> Bring to Front, (the same commands are available from the right
mouse click menu) then position the backshell shape to overlap with
the connector shape.

Re-size the backshell to the proper size. Align the backshell with the
connector to the proper engagement position.

Click on the “Save” button.

8. After the backshell is created and saved, click on the “Linkage” (used to be
Drawing) tab.

a.

January, 2011
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The “Part Number” text box should display the part number of the
newly created backshell. If it is not displayed, manually type it in; click
on the “Fetch” button to open the side view of the backshell.
Type in the part humber of the connector that is associated with this
backshell and click “Fetch.” If the connector has not been designed
yet, step 7 must be completed when the connector is available.
Click on the backshell shape. From the toolbar, select Shape => Order
=> Bring to Front, (the same commands are available from the right
mouse click menu) then position the backshell shape to overlap the
connector shape.
Align the connector and backshell to the proper engagement position.
Click on the “Save” button.
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Import and Export components

1. Import
a. Go to File=>Import, left mouse click on Import to open dialog box
“Open”
b. Navigate to the directory where you have component’s XML file,
highlight it and click button “"Open”
c. Click OK on confirmation message
2. Export
a. Go to File=>Export, left mouse click on Export to open screen “Export
Components”
b. Select Category, Type and Manufacturer
c. Only components created by designer, or previously imported into
database will be shown
d. Check all check boxes for components that have to be exported
Click on “Export” button to open dialog box “Save As”
Navigate to the folder where you want to export XML file, type-in file
name and click on “Save” button
g. Click OK on confirmation message

0

Functionalities - Listing

Loading IPN

System Setup

MCAD Setup

Barcode

Netlist options

Wires connectivity Import/Export
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