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Lesson 1: Introduction 

Using This Book 
 The SAE BAJA Electrical project helps you to create electrical schematics using SOLIDWORKS 
Electrical to integrate the schematics with your 3D model. 

What is SOLIDWORKS Electrical (SWE) Software? 

SOLIDWORKS Electrical is a schematic software with an expandable set of libraries to design complex 
electrical systems.  The automated design and management tools helps to simplify the design tasks 
from terminal block to cross-reference assignments. 

SOLIDWORKS Electrical 3D is an active add-in for SOLIDWORKS CAD which enables you to place 
electrical components and use the SOLIDWORKS routing technology to automatically interconnect the  
electrical schematic design within the 3D model. 

Please note, that SOLIDWORKS Electrical Professional provides a license of both SWE Schematic 
Professional and SWE-3D. 

 

Prerequisites 

Before you start the SAE BAJA Electrical project, you should install ‘SOLIDWORKS Electrical’ and go 
through the tutorials that are integrated in SOLIDWORKS software. 

Conventions used in this book 

Convention Meaning  

Bold SOLIDWORKS Commands and options represented in this style 

Bold Italic SOLIDWORKS CAD files are represented in this style  

 

Getting started with SOLIDWORKS Electrical  
 

 SOLIDWORKS Electrical Schematic is a standalone program  

 SOLIDWORKS Electrical 3D is an add-in for SOLIDWORKS 
 
SOLIDWORKS Electrical Schematic is launched from the Windows start→ Programs→ SOLIDWORKS 
2018→ SOLIDWORKS Electrical. 
 
Download the zip files attached and extract the files. 
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Projects Manager 
 
The Projects manager will be automatically displayed when the software is started. Through this interface 
you can create a new project, open/duplicate, archive/unarchive and the change properties of an existing 
project. 
 

 
 
 
To ‘Start’ a new project:  

 Click ‘New’ 

 Select the project template ‘ANSI’, click ‘OK’ 

 Select language as ‘English’ click ‘OK’ 

 Enter the name of the project as ‘SAE BAJA ELECTRIC’ 

 Enter the required information in the properties dialog box 
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Lesson 2: Draw a Line Diagram 

 Insert a line diagram symbol 

 Create a line diagram symbol  

 Associate symbol to manufacturer part 

 Create a manufacturer part 

 Modifying existing manufacturer parts and circuits 
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Insert a line diagram symbol: 
Open ‘1-Document book’ and double click on ‘Line diagram’ to open. 

 The Line diagram page opens in the graphics window 

 Click on ‘line diagram’ -> ‘Insert symbol’  

 A palette is displayed showing the last placed symbol. Click on ‘other symbol’ (If it is first time that 
SW Electrical is used on the system, ‘symbol selector’ opens automatically) 

 

 

 In the symbol selector window, open the classification ‘Motors’  

 Highlight the Motor and click ‘Select’ to return to the drawing  

 Click the left mouse button to insert the symbol on the extreme right corner as shown 

 Click ‘OK’ to insert the symbol 
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Similar to Motor add the other symbols to the line diagram as shown. 

 

No. Classification Symbol 

1 Power supplies  Cells Battery 

2 Buttons, switches  Emergency stop button(2) 

3 Signaling, alarm Red/Green Indicator(1/1) 

4 Buttons, switches Switch(3) 
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Create a line diagram symbol: 

 Go to the ‘Library’ tab in SOLIDWORKS Electrical and select the ‘Symbols manager’ command. The 
Symbols manager dialog box appears as shown below  
 

 

 Click on ‘New’. This will allow you to create a brand new symbol (Note: you can copy and edit the 
symbol as required) 

 Enter the relevant properties in the dialog box: 
Name: ‘Reverse alarm’ 
Description: ‘Buzzer when reverse is activated’ 
Class: ‘Signaling/ Alarm’ 
Symbol type: ‘Line diagram symbols’ 
Unit system: ‘Metric’ 

 Click ‘OK’ to add the symbol to the library 

 Close the Library 
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Draw/ Update the symbol 

 Locate the symbol ‘Reverse alarm’ in the 

symbols manager. Open the symbol an empty 

drawing is opened with origin at (X: 0) ;( Y: 0) 

 Click on the ‘Draw’ tab and select ‘Rectangle’ 

 In the Command window enter the start point 

coordinates as (0, 0), click the ‘green check 

mark’  

 Specify the opposite corner as (50, 50) 

 Draw lines as shown in figure to display the 

name and properties of the symbol 

 

 

 To change the line type, select the line. The ‘graphical properties’ tab opens up on the right side of 

the window. Change the line type to ‘CENTER AXES’ 

 Go to the ‘Edit symbol’ Tab located on the toolbar and select ‘Insert attribute’ 

 Select  the following attributes as shown below to represent the data of the symbol 

 Select the position to place the attributes. You can change the order or position of each attribute 

by drag and drop 

 Go to the ‘Draw’ tab. Click on ‘Insert image’ select the image file that you need to insert 

 The file format should be ‘.bmp’ 

 Open the ‘SW_CADPARTS.Zip’ file. Insert the ‘Reverse alarm.bmp’ image 

Close the symbol by clicking the ‘x’ mark on the tab, SOLIDWORKS will automatically ask you to save the 
changes. Click on ‘Yes’ to save the changes to the drawing.  
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Go to the Line Diagram Tab and Insert the symbol you created as shown. 
 
Now you have successfully inserted all the line diagram symbols. 
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Associating symbol to manufacturer parts 
 
Manufacturer Parts: 
 
These are key to understanding the flow of information in SOLIDWORKS Electrical and are different from 
the SOLIDWORKS parts. Technically, these parts are ordered, purchased, installed and connected. 
Every manufacturer’s part has different technical data related to its classification. By default, 
SOLIDWORKS Electrical only has a few manufacturer’s parts that are added to the database after 
installation, it is possible to add new custom manufacturer parts or unarchive manufacturer’s data from 
the online content portal. 
 
Adding manufacturer parts to the components: 

 Right click on the reverse alarm 
symbol and go to ‘Component 
properties’ 

 Go to ‘Manufacturer part and 
circuits’ and click on ‘Search’ 

 It will open the ‘Manufacturer part 
selection’ window 

 There are multiple ways you can add 
manufacturer part to the line 
diagram symbol 

 You can go to the ‘Classification’ tab 
and go to ‘Signaling, Alarm’  and 
select option ‘Sounding’ and search 
for part ‘15323 RO BUZZER 12 VOLT’ 
from ‘Schneider electric’  

(Or) 

  You can go to ‘Filters’→ ’Remove Filters’ → enter ‘15323’ in the ‘Reference’ section 

 You can filter the manufacturer parts using different classifications such as ‘class’; ’Library’; ’Type’; 
’manufacturer’; ’Number of circuits and terminals’ 

 Select the manufacturer part and click on the ‘+’ symbol to add the selected manufacturer part 

 To remove a manufacturer’s part, click on the manufacturer’s part so it is highlighted. Then click 
on the red ‘ – ‘ symbol 

 Click ‘Select’ to confirm the selection and click ‘OK’ to add the part to the symbol 

 If you cannot find the part ‘15323,’ add another part from the same classification 
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Create a Manufacturer part 
 

 Go to the ‘Library’ tab and select ‘Manufacturer parts manager.’  The Manufacturer parts manager 
window will open up, showing the list of available manufacturer parts 

 Click on ‘Add manufacturer part’  and enter the part information 
 

 
 
Reference: ’B&S ENGINE/Motor’ 
Manufacturer: ‘B&S’ 
Class: ‘Motors’ 
Library: ‘User’ 
Description: ‘B&S Engine’ 
Click on ‘OK’ to add the part to the library. 

 

 Add the newly created manufacturer part to the ‘B&S ENGINE/motor’ in your line diagram 
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Modify the existing Manufacturer parts and Circuits: 

 Select the switch ‘S3’ which connects the battery to the brake indicator (red light symbol) 

 Right click the component and select ‘component properties.’ Go to ‘manufacturer parts and 
circuits.’ Remove the filters and “search” for reference number ‘16018’ 

 Add the manufacturer part and click ‘select.’ It will redirect back to the component properties 
window 

 Select the manufacturer part which was added and double click on it  

 ‘Manufacturer part properties…’ window will open for the selected manufacturer part 

 On the top tab, click on “Circuits, Terminals” 

 Click on ‘Add multiple.’ ‘Add circuits to manufacturer part’ window will open up. Click on ‘Add’ 

 It will add the circuit and terminals as required, by default it will add ‘1’ circuit and ‘2’ terminals 
 

 
 

 Click on the drag down button in circuit type and select ‘switch.’ Click ‘OK’ 

 Add terminal marks, which make the detailed cabling easy. To add the terminal marks, select the 
first circuit (with the number ‘0’) 

 In the terminals window located below, go to the “Mark” column and enter ‘0’ in the first row and 
‘1’ in the second row 

 Similarly, add the terminal numbers for second circuit as ‘2’ and ‘3’ consecutively 

 ‘Replace manufacture part’ window opens up and will display two options. Select option ‘Modify 
this component only’. Click ‘OK’ 

 The manufacturer part is updated and added to the symbol 
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 Similarly add the following manufacturer parts and update them as mentioned in the table with 
the correct number of circuits and terminals. This is critical for the next lesson “Detailed Cabling”.  
 

Line diagram symbol Reference number for 
manufacturer part 

Is the part updated 
(Y/N) 

Total Number of 
circuits (C) and 
terminals (T) 

Kill switch XB4BT845 N 2C 4T 

Green Indicator 3SB3612-6BA30 N 1C 2T 

Switch(S4) 16018 Y (Type: Switch) 2C 4T 

Switch(S5) 027438 Y (Type: Switch) 3C 6T 

Red Indicator ZBVB1 Y (Type: Signaling, Alarm) 2C 4T 

Battery 200017 Y (Type: Power supply) 4C 8T 

 
 

Update the terminal numbers for all the manufacturer parts associated to the line diagram 
symbols. If you cannot find the specific manufacturer part, add another part from the same 
classification. 
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Lesson 3: Detailed Cabling 

 Draw cables between the components/line diagram symbols 

 Create a new cable 

 Detailed cabling: Associate cable between the components 
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Draw cables between components/line diagram symbols  

 Go to the ‘Line diagram’ tab, select ‘Draw cable’ 

 The cable style manager opens up. Select ‘F01’ (Red continuous line). You may need to 
manually change the color of the line.  Click on “Color” and a Color palette will open up.  Choose 
Red.  

 You can see the pointer changes to green when you pass the mouse pointer on the top of a 
symbol 

 When you connect two components the color of the pointer changes its color when an active 
connection is made between two components 

 You will know if the connection is active by zooming in on the connection and noticing a dot 
on the outline of the symbols.  
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 Connect the line diagram symbols as shown  

 Repeat the process by drawing the cables to inter connect all the components 

 The ‘Esc’ key will stop creating the cables 
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Create a new cable: 

 The SOLIDWORKS library has a wide range of cables available 

 If you cannot find the required cable, you can create your own cable with the desired 
properties and add it to the library  

 Go to the ‘Library’ tab→ ’cables reference manager’→ “AWG” in Classifications → ‘new 
reference’ and enter the ‘cable reference properties’ as shown 

 

 Size standard: ‘Section (mm2)’ 

 Conductor section:  ‘0.5’ 

 Diameter of the cable:  ’2’ 

 Bend radius :  ‘0’ 

 After entering the data go to the ‘Cable cores’ tab and click ‘add’ to add the cable cores to the 
new cable as shown 
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Click ‘OK’ to add the cable to the library. 

 

Detailed cabling: Associate cable between the components 

 Select the cable passing through the ‘Battery’ and ‘Kill switch 1’ 

 In the ‘line diagram’ tab click ‘Detailed cabling’ 

 In the detailed cabling window, click on ‘Add a cable.’ It will open the ‘Cable references selection 
window’ 

 Click on ‘Remove filters.’ Enter ‘Project’ in the reference section. The newly created cable will 
be displayed 

 Select the cable and click on the ‘+’ sign to add the cable and click ‘select’. This will add the 
cable to the detailed cabling window 

 Add the first circuit first terminal of the battery to the positive end of the battery by drag and 
drop method. This is going to be a time taking process 

 If errors are encountered here, please review the previous section - “Modify the existing 
Manufacturer part Circuits and Terminals:” on page 13 

 Similarly add first circuit second terminal of the battery  to negative end of the battery 

 Similarly add the first circuit first and second terminals of the Kill switch 1 to the positive and 
negative ends of the cable 

 Click ‘close’ to finish the process 

 The wire number and reference name is displayed on the wire 

 

You have successfully created a cable between two components ‘Battery’ and ‘Kill switch’ 

Follow the same process and add a cable from detailed cabling for all the cables and assign terminals 
to the components. 
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Go to the ‘Project’ tab and click on cables and expand the project to see the cables connecting 
components, origin and destination of the cable, cable cores reserved to the link. 

 

The window shows all the cables that are connected. 

Save your project by clicking on ‘File’  ‘Save’. 

SOLIDWORKS Electrical saves the project in default location. 
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Lesson 4:  SOLIDWORKS Parts – Add Electrical Connection points (CPoint) 

 Create a 3D part to associate with the line diagram symbol 

 Create a connection point (CPoint) using Electrical Component Wizard 

 Create a cable connection point (Cable CPoint) 
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Create a 3D part to associate with the line diagram symbol 

 Download the ‘SW_CADPARTS.zip’ file  

 Open ‘Reverse_light.SLDPRT’ form ‘SW_CADPARTS’ folder 

 Go to ‘Tools’ -> ‘Add-Ins’ -> add ‘SOLIDWORKS Electrical’ add-in  and click ‘OK’ 
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Create a connection point (CPoint) using Electrical Component Wizard 

 Go to ‘Tools’ -> ‘SOLIDWORKS Electrical’ -> ‘Electrical component Wizard’ 

 It will open the ‘Routing Library Manager’ (RLM) window  as shown 
 

 

 Select the point type to ‘CPoint with circuit information’. Click ‘Add’ to continue 

Note: The circuit number and connection point number represent the circuit number of the part 
which is going to be linked with the SOLIDWORKS Electrical part and the connection point number 
represents the index of the circuit. 
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  For ‘Reverse _light’ the circuit and index numbers are shown below 

  

 The circuit and index numbers should be entered correctly when you assign the CPoints to the 
3D parts in order to successfully complete the next sections 

 Enter the circuit number as ‘0’ and the connection point number as ‘0’ 

 Select the sketch point as shown 
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 Click on ‘OK’ to confirm the selection and to add the ‘CPoint’ to the part 

 The Routing Library Manager opens after adding the CPoint to the part. Select the CPoint with 
circuit information and click ‘Add’ 

 Repeat the same process for the second CPoint and enter circuit number as ‘0’ and connection 
point number as ‘1.’ Select the other point on sketch 9 

 

Create a cable connection point (Cable CPoint) 

Cable CPoint is the starting point for the cable. It is important to add the Cable CPoint to the 3D part 
to begin the route of the cables.  After successfully adding the connection points to the part, the 
routing library manager will open automatically 

 Select ‘Cable CPoint’ and click ‘Add’ 

 Select the ‘point’ on ‘plane 2’ 

 Click ‘OK’ to confirm the selection and to add the Cable Connection Point to the part 

 Close the ‘Routing Library Manager’ 

 Save the SOLIDWORKS file 

You have successfully created the ‘Connection points’ for the cable cores and ‘Cable connection point’ 
for the cable. 

 Open ‘Allcomponents_assembly.SLDASM’  

 Insert the ‘Reverse_light.SLDPRT’ into the assembly and mate it using coincident and concentric 
mates to fully define the assembly as shown 

 The other parts have their respective CPoint and Cable CPoint included and are ready for use 

 Save the assembly and close the assembly file 
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Lesson 5: SOLIDWORKS Electrical 3D 

 Open Electrical projects in SOLIDWORKS 

 Insert/ Associate the electrical components to 3D parts 
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Open Electrical projects in SOLIDWORKS 

Open ‘SOLIDWORKS Electrical’ → open your project from the ‘Projects manager’ window. 

 Go to ‘Process’ tab. Click on add ‘SOLIDWORKS assembly’ 

 Since you have only one location associated with the project, (L1), you can add any one of those 
to the project 

 

 Click ‘OK’ to generate SOLIDWORKS 3D assembly files 

 ‘ANSI Template project’ appears on the document tree 

 It opens the project as shown  

 Double click on the ‘ANSI Template project’ to open 
SOLIDWORKS 
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You can open the electrical project from SOLIDWORKS  

 Open ‘SOLIDWORKS’ 

 Go to ‘Tools’ → ‘SOLIDWORKS Electrical’ → ‘Projects manager’ → ‘SAE BAJA ELECTRIC’ → ‘Open’ 

 On the right side you can see your electrical project. Expand the document tree and open the 
‘ANSI Template project’ 
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Insert/ Associate the electrical components to 3D parts 

 Open the Electrical manager and expand the project to see list of electrical components 
present in the project. You can see it on the left side on the above picture 

 Note: If the electrical manager does not appear, close the assembly and open it back up from 
clicking on the “ANSI Template Project” from within SOLIDWORKS. This can be seen on the 
right in the picture above 

 Go to ‘Assembly’ tab and click on ‘Insert components’ to insert the assembly file 

 Open ‘All components_assembly.SLDASM’ file from the ‘SW_CADPARTS’ folder 

 You can hide the origins of each part to make the view better 

 You can  Insert/Associate the electrical components in multiple ways 

 Since we have the assembly ready we can associate the electrical components to the 3D parts 
by following process: 

 In the ‘Electrical manager’, right click the ‘Battery 12V 5A’ and click on ‘Associate’ 

 ‘Associate component’ command window opens up. Expand the assembly tree and select 
‘Battery’, click ‘Ok’ to associate battery to 3D part 

 Similarly associate all the electrical components to their respective 3D parts 

 You can check mark  ‘Hide already inserted components’ to avoid confusion of adding the same 
component to multiple parts 
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Lesson 6: Routing Cables 

 Routing cables 

 Create Routing Paths  

 Route cables  

 Flattening the route  

 Adding the Bill Of Materials(BOM) to the drawing 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



Page | 31  

 

Routing Cables 

Cables can be automatically routed between parts in an assembly where specific criteria are met. 

 3D parts must be associated to SOLIDWORKS Electrical components  

 The Electrical component must have detailed cabling connections in SOLIDWORKS Electrical 
Schematic 

 The 3D part must have CPoint and Cable CPoint with a naming convention that matches the 
components circuit and terminal data 

 Sketch paths with a specific naming convention must be used  

 Routing parameters specified must allow the program to locate paths and component 
connection points  
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Create Routing paths 

 The Routing path is used to guide the route of the cables through the assembly.  

 Sketch names mush include ‘EW_PATH’ to be recognized as a path when routing. Names 
like EW_PATH1, EW_PATH2 are valid 

 Go to ‘SOLIDWORKS Electrical 3D’  ‘Create Routing Path’  ‘Create sketch’  ‘OK’ 

 Create a 3D sketch using the ‘EW Cable_Point’ of the Electrical 3D parts, use lines or splines 
to create the paths of the cables 

 This is the most important part in the project. Create the 3D sketch to route the cables  

 If the sketch is not feasible ( Over defined ) or has any errors, SOLIDWORKS cannot generate 
the cables in that region(between those components) 

 One of the ways is shown  
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Route Cables: 

Go to ‘SOLIDWORKS Electrical 3D’ tab, click on ‘Route cables’ 

 Route cables property manager opens and shows the 
following options for routing cables. 

Routing analysis: 

 Select the option ‘Show errors’, to show the errors 
while routing cables 

Select Route type 

 SOLIDWORKS Route: This option is used to create the 
finished route including the routing sub-assemblies 
and physical cable parts 

o This will take a while depending upon the 
complexity of the electrical system 

 3D sketch Route: This option is used to create a quick 
preview of the route using sketch geometry 

Renderer type: 

 Splines and lines are the two main renderer types 
used in SOLIDWORKS 

Routing parameters: 

 The Routing parameters are available regardless 
of the type of route being created. They allow you 
to define the distances the program will analyze 
to locate sketch paths and CPoint (0_0) 

  Routing parameters can mean a connection 
point cannot locate certain EW_PATH sketches 
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Route the cables by the following settings 

 SOLIDWORKS Route  

 Use splines 

 Add tangency check 

 All components 

 Routing parameters  60mm—120mm—0.5mm 

 Click ‘OK’ to generate the cables between components 

 

The final assembly is shown below, the path of the cables changes depending upon your 3D sketch. 
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Go to SOLIDWORKS Electrical 3D tab, click on Update BOM (Bill of Materials) properties. 

 This will automatically update the route lengths in SOLIDWORKS Electrical 

 Go to ‘Project’ tab. Select ‘Reports’ 

 Click on ‘Add.’ Report configuration selector window opens, which shows the available default 
report templates available in SOLIDWORKS Electrical 

 Select ‘List of cables grouped by reference’, ‘Bill of materials grouped by manufacturer’. 

 The reports are generated as requested 

 

 The length of cables can be seen. Similarly, you can generate the required reports 
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Flattening the Route:  create a flattened (harness-board) drawing of the 3D harness model:  

 The route can be flattened for use in manufacturing. Add the “SOLIDWORKS routing” add in 
feature to SOLIDWORKS. 

 Go to ‘Tools’ -> ’Add-Ins’ ->’SOLIDWORKS Routing’ 

 Go to ‘Electrical’ tab -> select ‘Flatten route’ option 

 Flatten Route manager opens up showing the different 
options available  

 Avoid collisions during user defined routing as it will cause 
errors during route flattening 

 Flatten type: 
o Annotation: Simplified representation of the route as 

flattened configuration and drawing, lines are not 
true lengths but the annotations display the actual 
length. 

o Manufacture: Specifies scaled representation of the 
route as flatten configuration and drawing. 

 Flatten options: 
o Display 3D connectors: Displays the 3D models of the 

connectors in the flattened route 
o Use drawing connector blocks: Displays the 2D 

connector blocks of the connectors in the drawing of 
the flattened route. 

 Select the following options to create the flatten route 

 Flatten type: ’Annotation’ 

 Flatten option: ‘Display 3D connectors’ 
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 Click ‘OK’ (green check mark) to create the route 

Edit the flatten route 

 Select the route, right click  and select ‘Edit flattened route’ 

 You can edit the route by default options like ‘Drag’, ‘Horizontal’, ‘Vertical’, ‘Delete relations’, 
‘Fan-out’  

 Edit the route as required 

 

Adding the Bill of Materials (BOM) to the drawing 

 Click on ‘Flatten route’ one more time to create a drawing and add the BOM tables 

 Select the following options 

 Sheet format : ‘a0 – landscape’  

 Select the ‘Electrical BOM’, ‘Cut list’, ‘Connector table’ to create the BOM tables on the drawing 

 Click ‘OK’ to create the drawing  

 Manually arrange the tables, annotations and harness views as desired.  (tip:  change to a larger 
drawing sheet format if needed) 



Page | 38  

 

 



Page | 39  

 

 

 

 Circuit summary table shows the lengths of the cables used and their respective lengths 
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 Go to ‘SOLIDWORKS Electrical Drawing’ -> select ‘Create Project Drawing’ to add the drawing 
sheet created to the SOLIDWORKS Electrical project 

 

 

Congratulations! You have successfully completed SAE BAJA Electrical project using SOLIDWORKS 
Electrical 2D and SOLIDWORKS Electrical 3D 

 


