The Fundamentals of SolidWorks® 2007

Featuring the VEXplorer™ robot with over 40 integrated stand-alone tutorials

David C. Planchard & Marie P. Planchard, CSWP

SDC PUBLICATIONS
Schroff Development Corporation
www.schroff.com
www.schroff-europe.com
CHAPTER 1: QUICK START

Chapter Objective

Chapter 1 provides a basic overview of the concepts and terminology used throughout this book using SolidWorks® 2007 software. If you are new to SolidWorks, you should read Chapter 1 in detail and complete Lesson 1, Lesson 2, and Lesson 3 in the online SolidWorks Tutorials under Help in the User Main menu.

Chapter 1 introduces you to many of the basic operations of SolidWorks such as: definitions, starting a SolidWorks session, using the User Main menu and Interface along with opening and closing files, creating a part, assembly, and drawing.

On the completion of this chapter, you will be able to:

- Comprehend what is SolidWorks
- Understand and apply basic concepts in SolidWorks:
  - A SolidWorks model, features, Base sketch, refining the design, associativity, drawings, and geometric constraints
- Start a SolidWorks session
- Use the SolidWorks User Interface (UI), and CommandManager
- Address the following Menus, Task Panes, Commands, and Screens:
  - SolidWorks Resources, Design Library, File Explorer, Search, Right-Click Pop-up menus, View Palette, PhotoWorks, Drop-down menus, Fly-out FeatureManager, System feedback, Confirmation Corner, and View Modes
- Create a New Part
- Create a New Assembly:
  - Insert Components and Mates
- Create a New Assembly Drawing:
  - Insert four standard views: Front, Top, Right, and Isometric
  - Insert a simple Bill of Materials
What is SolidWorks?

The SolidWorks application is a mechanical design automation software package used to create parts, assemblies, and drawings which takes advantage of the familiar Microsoft Windows graphical user interface.

SolidWorks is an easy to learn design and analysis tool; (COSMOSWorks, COSMOSFloWorks, and COSMOSMotion) which makes it possible for designers to quickly sketch 2D and 3D concepts, create 3D parts and assemblies, and detail 2D drawings.

In SolidWorks, a part, an assembly, and a drawing are all related as illustrated. The book is focused for the new user and assumes that you have little or no working knowledge of SolidWorks.

Basic Concepts in SolidWorks

Below is a list of basic concepts in SolidWorks to review and to comprehend. These concepts are applicable to all versions of SolidWorks. All of these concepts are addressed in this book.

- **A SolidWorks model.** Consists of 3D solid geometry in a part or assembly document. SolidWorks features start with either a 2D or 3D sketch. You can either import a 2D or 3D sketch or you can create the sketch in SolidWorks.

- **Features.** Individual shapes created by Sketch Entities tools: Lines, Circles, Rectangles, etc. that when combined, creates the part. Features can also be added to assemblies. Some features originate as sketches; other features, such as shells or fillets, are created when you select the appropriate tool or menu command and define the dimensions or characteristics that you want.

- **Base sketch.** The first sketch of a part is called the Base sketch. The Base sketch is the foundation for the 3D model. Create a sketch on a default plane or created reference plane. The default planes are: Front, Top, and Right Plane in the FeatureManager design tree.
• **Refining the design.** Adding, editing, or reordering features in the FeatureManager design tree. Example: For a part document, you can perform the following types of feature editing operations:
  
  • Edit the definition, the sketch, or the properties of a feature.
  • Control the access to selected dimensions.
  • Roll back the part to the state it was in before a selected feature was added.
  • View the parent and child relationships of a feature.
  • Use the feature handles to move and resize features.
  • Modify the order in which features are reconstructed when the part is rebuilt.

• **Associativity.** A SolidWorks model is fully associative. Associativity between parts, sub-assemblies, assemblies, and drawings, assures that changes incorporated in one document or drawing view are automatically made to all other related documents and drawing views.

• **Drawings.** Create 2D drawings of the 3D solid parts and assemblies which you design. Parts, assemblies, and drawings are linked documents. This means that any change incorporated into the part or assembly changes the drawing document. A drawing generally consists of several views generated from the model. Views can also be created from existing views. Example: The Section or Projected view is created from an existing drawing view.

• **Constraints.** SolidWorks supports numerous constraints. Constraints are geometric relationships such as Perpendicular, Horizontal, Parallel, Vertical, Coincident, Concentric, etc. Use equations to establish mathematical relationships between parameters. Apply equations and constraints to your model to capture and maintain design intent.

---

**Starting a SolidWorks Session**

Start a SolidWorks session and familiarize yourself with the SolidWorks User Interface (UI). As you read and perform the tasks in this chapter, you will obtain a sense on how to use this book and the structure. To help you learn the material, short quick tutorials are provided throughout the chapters. Actual input commands or required action to perform functions in the tutorial is displayed in bold.

⚠️ SolidWorks is designed to run on Windows XP Professional with a minimum of 512 MB RAM. If you are using a network license version of SolidWorks, use the Windows XP Server Edition.
The book was written using SolidWorks Office 2007 on Windows XP Professional SP2 with a Windows Classic desktop theme. Start a SolidWorks session. The SolidWorks application is located in the Programs folder.

**Tutorial: Start a SolidWorks Session 1-1**

1. Click **Start ➤ All Programs ➤ SolidWorks 2007 ➤ SolidWorks 2007** from the Windows taskbar. The SolidWorks program window opens as illustrated. Do not open a document at this time. If you do not see this screen, click the **SolidWorks Resources** icon in the Task Pane on the right side of the SolidWorks Graphics window.

2. **Read** the Tip of the Day.

   Double-click the **SolidWorks 2007 icon** in the Windows Desktop to start a SolidWorks session.


---

**SolidWorks User Interface (UI)**

The Task Pane is displayed when a SolidWorks session starts. The Task Pane can be displayed in the following states: Visible or hidden, Expanded or collapsed, Pinned or unpinned, Docked or floating.


- The Document Recovery tab is displayed if your system terminates unexpectedly with an active document; power outage or abnormal termination.

- The PhotoWorks Items tab is displayed if PhotoWorks is installed.
SolidWorks Resources

Utilize the left/right arrows » or click and drag the box to expand or collapse the Task Pane options. The basic SolidWorks Resources menu displays the following default selection tabs: Getting Started, Community, Online Resources, and Tip of the Day.

Other user interfaces are available to be displayed; Machine Design, Mold Design, or Consumer Products Design during the initial software installation selection. The book utilizes the Machine Design user interface as illustrated.

Design Library

The Design Library contains reusable parts, assemblies, and other elements, including library features.

The Design Library tab contains four default selections. Each default selection contains additional subcategories. The selections are: Design Library, Toolbox, 3D ContentCentral, and SolidWorks Content.

Click Tools > Add-Ins > SolidWorks Toolbox and SolidWorks Toolbox Browser to active the SolidWorks Toolbox.

To access the Design Library folders in a non network environment, click Add File Location, enter: C:\Programs Files\SolidWorks\data\design library. Click OK.

In a network environment, contact your IT department for system details.

File Explorer

File Explorer duplicates Windows Explorer from your local computer and displays the following directories: Recent Documents, and Open in SolidWorks.
Search

Microsoft Windows Search is installed with SolidWorks and indexes the resources once before searching begins, either after installation, or when you initiate the first search.

The SolidWorks Search box is displayed in the upper right corner of the SolidWorks Graphics window. Enter the text or key words to search. Click the drop down arrow to view the last 10 recent searches.

The Search tool in the Task Pane searches the following locations: All locations, Local Files, Design Library, SolidWorks Toolbox, 3D ContentCentral, and Added location.

Select any or all of the above locations. If you do not select a file location, all locations are searched.

View Palette

Use the View Palette tool located in the Task Pane to insert drawing views of an active model or click the Browse button to locate the desired model.

Click and drag the view from the View Palette into an active drawing sheet to create the drawing view.

Auto Recovery

If auto recovery is initiated in the System Options section and the system terminates unexpectedly with an active document, the saved information files are available on the Task Pane Document Recovery tab.

PhotoWorks

PhotoWorks create photo-realistic images of SolidWorks models. PhotoWorks provides many professional rendering effects. PhotoWorks contains the following default folders: Scene, Materials, Decals, and Lighting. View the SolidWorks Tutorials for additional information.
Click **Tools ➤ Add-Ins ➤ PhotoWorks** from the Main menu to activate the PhotoWorks feature.

### Drop-Down Menu

SolidWorks takes advantage of the familiar Microsoft® Windows® graphical user interface. Communicate with SolidWorks through the drop-down menus or the application toolbars. A command is an instruction that informs SolidWorks to perform a task.

To close a SolidWorks drop-down menu, press the Esc key. You can also click any other part of the SolidWorks Graphics window, or click another drop-down menu.

The drop-down menu options perform three basic functions. They are:

1. Displays a SolidWorks dialog box.
2. Submits a command to create or modify your drawing.
3. Offers an expanded set of tools located in the SolidWorks Toolbars.

### Fly-out FeatureManager

The fly-out FeatureManager design tree allows you to view and select items in the PropertyManager and the FeatureManager design tree at the same time. The fly-out FeatureManager provides the ability to select items which may be difficult to view from the Graphics window. You can hide, modify the transparency of, go to, or zoom to selected items. You cannot suppress items or roll back the build. Throughout the book, you will select commands and command options from the drop-down menus, fly-out FeatureManager, or from the SolidWorks main toolbars.

Another method for accessing a command is to use the accelerator key. Accelerator keys are special keystrokes which activates the drop-down menu options. Some commands in the menu bar and items in the drop-down menus have an underlined character. Press the Alt key followed by the corresponding key to the underlined character activates that command or option.
Right-Click Pop-up menus

Right-click in the Graphics window to display a context-sensitive shortcut menu. If you are in the middle of a command, this menu displays a list of options specifically related to that command. Example: if you right-click your mouse before picking the first point of the Rectangle tool, a menu is displayed in the Graphics window. The menu displays Sketch Entities, Selected Entity, and other Relations and menu options.

FeatureManager Design Tree

The FeatureManager design tree is located on the left side of the SolidWorks Graphics window. The FeatureManager provides a summarize view of the active part, assembly, or drawing. The FeatureManager design tree displays the details on how your part, assembly, or drawing is created.

Understand the FeatureManager design tree to troubleshoot your model. The FeatureManager is use extensively throughout this book. Expand, collapse, and scroll the FeatureManager design tree.

💡 To collapse all items in the FeatureManager, **right-click** and select **Collapse items**, or press the **Shift + C** keys.

💡 Roll back a feature with the rollback bar in the FeatureManager design tree. The rollback bar is a yellow and black line which turns blue when selected. Click and drag the **rollback bar** up or down the FeatureManager design tree to step forward or backward through the regeneration sequence.

💡 You can save your models with the rollback bar in any location of the FeatureManager design tree.

The FeatureManager design tree and the Graphics window are dynamically linked. Select sketches, features, drawing views, and construction geometry in either pane. Split the FeatureManager design tree and either display two FeatureManager instances, or combine the FeatureManager design tree with the ConfigurationManager or PropertyManager.
Move between the FeatureManager design tree, PropertyManager, ConfigurationManager, and Render Manager by selecting the tabs at the top of the menu.

The ConfigurationManager is located to the right of the FeatureManager. Use the ConfigurationManager to create, select, and view multiple configurations of parts and assemblies.

Split the ConfigurationManager and either display two ConfigurationManager instances, or combine the ConfigurationManager with the FeatureManager design tree, PropertyManager, or a third party application that uses the panel. The icons in the ConfigurationManager denote whether the configuration was created manually or with a design table.

**System Feedback**

SolidWorks provides system feedback by attaching a symbol to the mouse pointer cursor arrow. The system feedback symbol indicates what you are selecting or what the system is expecting you to select. As you move the mouse pointer across your model, system feedback is provided to you in the form of symbols, riding next to the cursor arrow.

**Confirmation Corner**

When numerous SolidWorks commands are active, a symbol or a set of symbols are displayed in the upper right hand corner of the Graphics window. This area is called the Confirmation Corner.

When a sketch is active, the confirmation corner box displays two symbols. The first symbol is the sketch tool icon. The second symbol is a large red X. These two symbols supply a visual reminder that you are in an active sketch. Click the sketch symbol icon to exit the sketch and to saves any changes that you made.

When other commands are active, the confirmation corner box provides a green check mark and a large red X. Use the green check mark to execute the current command. Use the large red X to cancel the command.
View Toolbar

SolidWorks provides the user with numerous view options from the View toolbar. The view options are from left to right: Previous View, Zoom to Fit, Zoom to Area, Zoom to Selection, Rotate View, Pan, 3D Drawing View, Standard Views (Normal To, Front, Back, Left, Right, Top, Bottom, Isometric, Trimetric, Dimetric), Wireframe, Hidden Line Visible, Hidden Lines Removed, Shaded With Edges, Shaded, Shadows In Shaded Mode, Section View, Real View Graphics.

Create a New Part

A part is a 3D model which consists of features. What are features?

1. Features are geometry building blocks.
2. Features add or remove material.
3. Features are created from 2D or 3D sketched profiles or from edges and faces of existing geometry.

SolidWorks provides two modes in the New SolidWorks Document dialog box: Novice and Advanced.

The Novice Mode is the default mode with three default templates.

The Advanced Mode contains access to create additional templates. In this book, you will use the Advanced Mode.

Before you begin the tutorials create a SolidWorks folder and copy the files from the CD in the book. Use these folders to create your models.
Create the Standoff Part

*Tutorial: New Part - Standoff 1-2*

Create a New part named Standoff.

1. Click **New** from the Standard toolbar.
2. Select the **Advanced Mode** from the New SolidWorks Document dialog box. The Templates tab is the default tab. Part is the default template from the New SolidWorks Document dialog box.
3. Click **OK** from the New SolidWorks Document dialog box. The Part FeatureManager is displayed.

   The Advanced mode remains selected for all new documents in the current SolidWorks session. The Advanced mode setting is saved when you exit SolidWorks. The default SolidWorks installation contains two tabs in the New SolidWorks Document dialog box: Templates and Tutorial.

   The Templates tab corresponds to the default SolidWorks templates. The Tutorial tab corresponds to the templates utilized in the SolidWorks Tutorials.

   In a SolidWorks session, the first system default part filename is named: Part1. The system attaches the .sldprt suffix to the created part. The second created part in the same session, increments to the filename: Part2. Part1 is displayed in the FeatureManager. The Main menu, Standard toolbar, and CommandManager are displayed above the SolidWorks Graphics window. The CommandManager is divided into the Control Area and an expanded toolbar. Select a Control Area icon to display the corresponding toolbar. The Features icon and Features toolbar are selected by default in the Part mode.

Save the Standoff part.

4. Click **File > Save** from the Main menu.

5. Select the folder **VEXplorer Models**.

6. Enter **Standoff** for the File name in the VEXplorer Models folder.

7. Click **Save**.

💡 Organize parts into file folders. Copy and use the folders on the CD in the book. Create a separate sub folder for your solutions.

💡 In a SolidWorks application, each part, assembly, and drawing is referred to as a document. Each document is displayed in a separate Graphics window.

**Define the Document Properties.**

8. Click **Options** from the Standard toolbar. Click the **Document Properties** tab.

9. Select **ANSI** from the Dimensioning standard box.

10. Click **Units**.

11. Select **MMGS** (millimeter, gram, second) for Unit system.

12. Select **2** for Length units decimal place. Select **0** for Angular units decimal place.

13. Click **OK** from the Document Properties - Units dialog box.

Create the 2D Sketch plane for the part. The Sketch plane is the plane on which a sketch lies and is configurable through the Sketch Plane PropertyManager. In SolidWorks, the name used to describe a 2D or 3D profile is called a Sketch.

💡 The Reference Triad is located in the lower left corner of the Graphics window. The Reference Triad displays the orientation of the model coordinate axes; (Red-X, Green-Y, and Blue-Z) at all times when activated.
The Reference Triad aids you to display how the view orientation is displayed relative to the Front Plane.

Create a 2D Sketch.

14. Click **Front Plane** from the FeatureManager design tree. This is your Sketch plane for the first feature. This is the Base sketch.

15. Click **Sketch** from the Control Area. The Sketch toolbar is displayed in the CommandManager.

16. Click **Circle** from the Sketch toolbar. The Sketch opens on the Front Plane in the Front view by default. The Circle PropertyManager is displayed.

17. Drag the **mouse pointer** into the Graphics window. The cursor displays the Circle feedback symbol. The center point of the circle is positioned at the Origin. The part Origin is displayed in the center of the Graphics window. The Origin represents the intersection of the three default reference planes. They are: Front Plane, Top Plane, and Right Plane. The positive X-axis is horizontal and points to the right of the Origin in the Front view. The positive Y-axis is vertical and points upward in the Front view.

The Front Plane rotates, and is parallel to the screen. This only happens for your first sketch in a part.

18. Click the **Origin** from the Graphics window. This is the first point of the circle. The red dot feedback indicates the Origin point location. The mouse pointer displays the Coincident to point sketch relation feedback symbol.

19. Drag the **mouse pointer** to the right of the Origin.

20. Click a **position** to create the circle.

   To control the Sketch relation display, click **View > Sketch Relations** from the Main menu.

Insert a Dimension.

21. Click **Smart Dimension** from the Sketch toolbar.

22. Click the **circumference** of the circle. The cursor displays the diameter feedback symbol.
23. Click a **position** to place the dimension in the Graphics window.

24. Enter **10mm** the Modify dialog box. Click the **green check mark** from the Modify dialog box. The circular sketch is centered at the Origin.

25. Press the **f** key to fit the sketch to the Graphics window.

💡 If your sketch is not correct, select **Undo** from the Main menu.

The Extruded Boss/Base feature adds material to a part. The Extruded Base feature is the first feature of the Standoff part. An extrusion extends a profile along a path normal (⊥) to the profile plane for some distance. The movement along that path becomes the solid model. The 2D circle is sketched on the Front Plane.

**Insert an Extruded Boss/Base Feature.**

26. Click **Features** from the Control Area.

27. Click **Extruded Boss/Base** from the Features toolbar. The Extrude PropertyManager is displayed. The Extrude PropertyManager displays the parameters utilized to define the feature.

28. Select **Mid Plane** for End Condition in Direction 1. The Mid Plane End Condition extrudes the sketch equally on both sides of the Sketch plane.

29. Enter **12mm** for Depth. The Depth defines the distance. Note the direction of the extrude relative to the Origin.

30. Click **OK** from the Extrude PropertyManager. Extrude1 is created and is displayed in the FeatureManager. Extrude1 is your Base feature.
To edit a feature, right-click the desired feature in the FeatureManager. Click Edit Feature. The PropertyManager is displayed.

Display an Isometric view.

31. Click Isometric view from the Reference Triad drop-down list.

The Extruded Cut feature removes material from a part. The Extruded Cut feature is the second feature of the Standoff part. An Extruded Cut extends a profile along a path normal (⊥) to the Sketch plane for some distance and removes material inside or outside the sketch. The 2D circle is sketched on the front face of the Standoff to create a hole.

Insert a Sketch.

32. Click the front face of Extrude1 in the Graphics window. The selected face in the Graphics window is displayed in green. Extrude1 is highlighted in the FeatureManager.

33. Click Sketch from the Control Area. The Sketch toolbar is displayed in the CommandManager.

34. Click Circle from the Sketch toolbar.

35. Click the Origin. Click a position to the right of the Origin. The circle is created.

Insert a dimension.

36. Click Smart Dimension from the Sketch toolbar. Click the circumference of the circle. The cursor displays the diameter feedback symbol. Click a position to place the dimension in the Graphics window.

37. Enter 3 mm in the Modify dialog box. Click the green check mark from the Modify dialog box. The circular sketch is centered at the origin.

Insert an Extruded Cut feature.

38. Click Features from the Control Area.

39. Click Extruded Cut from the Features toolbar. The Cut-Extrude PropertyManager is displayed.
40. Select **Through All** for End Condition in Direction 1.

41. Click **OK** from the Cut-Extrude PropertyManager. Cut-Extrude1 is displayed in the FeatureManager.

Edit the color of the Standoff part.

42. Click the **Standoff** icon from the FeatureManager.

43. Click **Edit Color** from the Standard toolbar. The Color and Optics PropertyManager is displayed.

44. Select a **color** from the Edit Color box as illustrated.

45. Click **OK** from the Color And Optics PropertyManager.

Modify a dimension.

46. Double-click the **Cut-Extrude1** feature in the FeatureManager.

47. Double-click the **Ø3** dimension.

48. Enter **1.00**mm in the Modify dialog box.

49. Click the **green check mark** from the Modify dialog box.

50. Click **Rebuild** from the Standard toolbar to update the dimensions.

51. Press the **f** key to fit the model to the Graphics window.

Close the model.

52. Click **File > Close** from the Main menu.

You completed the Standoff part using the Extruded Base/Boss feature with the Mid Plane End Condition option. The Extruded Cut feature was used to create a Through All hole. You also applied a color to the part with the Edit Color tool to control part and feature color and modified an existing dimension.

💡 To edit a sketch, right-click the desired **sketch** in the FeatureManager. Click **Edit Sketch** or **Edit Sketch Plane**.
Create a New Assembly

An assembly is a document that contains two or more parts. An assembly inserted into another assembly is called a sub-assembly. A part or sub-assembly inserted into an assembly is called a component. Create the Gear assembly consisting of the following components: Standoff2 and Gear28.

Establishing the correct component relationship in an assembly requires forethought on component interaction. Mates are geometric relations that align and fit components in an assembly. Mates remove degrees of freedom from a component. Mates reflect the physical behavior of a component in an assembly. The components in the Gear assembly utilize Standard Mate types only.

SolidWorks Help Topics list the rules governing Mate Type valid geometry.

Tutorial: New Assembly - Gear 1-3
Create a New assembly named Gear. First open the Standoff2 part.

1. Click Open  from the Standard toolbar. Double-click the Standoff2 part from the VEXplorer Models folder. You copied this folder from the CD-ROM in the book.

Create a New assembly.

2. Click New  from the Standard toolbar.

3. Double-click the Assembly icon from the New SolidWorks Document dialog box. The Insert Component PropertyManager is displayed.

The Insert Component PropertyManager is displayed when the Start command when creating new assembly option box is checked.

Insert the Standoff2 part.

4. Click View; check Origins from the Main menu.

5. Click Standoff2 from the Part/Assembly to Insert box.

6. Click the Origin in the Graphics window. Assem1 is displayed in the FeatureManager and is fixed to the Origin, (f).
Quick Start

7. Click **File > Save As** from the Main menu.

8. Select the **VEXplorer Model** Save in folder. Enter **Gear** for File name.

9. Click **Save**. The Gear Assembly FeatureManager is displayed. Standoff2 is the first component in the Gear assembly and is fixed (f).

   Insert the Gear28 part.

10. Click **Insert Component** from the Assembly toolbar.
    The Insert Component PropertyManager is displayed.

11. Click **Browse** from the Part/Assembly to Insert box.

12. Double-click the **Gear28** part from the VEXplorer Models folder. The Gear28 part is displayed in the Graphics window.
    Note: Select part for Files of type.

13. Click a **position** in the back of the Standoff2 component as illustrated.

14. Press the **f** key to fit the model to the Graphics window.

15. Click and drag the **Gear28** component if required as illustrated.
    Deactivate the Origins.

16. Click **View**; uncheck **Origins** from the Main menu.

    The wheel mouse button or middle mouse button controls Zoom In/Out in the Graphics window. Use Ctrl+middle mouse button to Pan. Hold the middle mouse button down to rotate the model in the Graphics window.

    Insert a Concentric Mate between the Standoff2 and the Gear28 component. A Concentric mate forces two cylindrical faces to become concentric. The faces can move along the common axis, but cannot be moved away from this axis.

    Insert a Concentric Mate.

17. Click **Mate** from the Assembly toolbar. The Mate PropertyManager is displayed.

18. Click the **inside cylindrical hole face** of Gear28 as illustrated. Note: the mouse pointer icon feedback for the selected face. Face<1>@Gear28 is displayed in the Mate Selections box.
19. Click the **long cylindrical face** of the Standoff2 component. The two selected faces are displayed in the Mate Selections box. The Concentric Mate type is selected by default. The Standoff2 component is positioned concentric to the Gear28 hole.

20. Click the **green check mark** from the Pop-up Mate box. Concentric1 is created.

21. Click and drag **Gear28** left to right. The Gear28 translates in and out along the Standoff2 component.

💡 Position the mouse pointer in the middle of the face to select the entire face. Do not position the mouse pointer near the edge of a face.

💡 If you select a wrong face or edge during the mate process, right-click in the Mate Selections box and select Clear Selections.

💡 If you delete a Mate and then recreate it, the Mate numbers will be in a different order.

A Coincident mate forces two planar faces to become coplanar. The faces can move along one another, but cannot be pulled apart. A Distance mate separates two planar faces by a specified value.

Insert a Distance Mate.

22. If required, clear the Mate Selections box.

23. Click the **front circular face** of the Gear28 component as illustrated.

24. Click the **front circular face** of the Standoff2 component as illustrated. The two selected faces are displayed in the Mate Selection box. Coincident is selected by default.

25. Click **Distance** from the Mate pop-up box.
26. Enter 5mm for Distance. Click the **Flip Dimension** button if required.

27. Click the **Green Check mark** from the Mate pop-up box. Distance1 is created.

28. Click **OK** from the Mate PropertyManager.

29. Press the f key to fit the model to the Graphics window.

30. Click **Isometric view**. **Expand** the Mates folder from the FeatureManager. View the created mates.

31. Click **Save**.

32. Click and drag the **front circular face** of Gear28. Gear28 is free to rotate about the Standoff2 component.

💡 Press the **Shift+ z** keys to Zoom in on the model. Press the **z** key to Zoom out on the model.

---

### Create a New Assembly Drawing

A SolidWorks drawing displays 2D and 3D views of a part or assembly. The foundation of a SolidWorks drawing is the drawing template. Drawing size, drawing standards, company information, manufacturing, and or assembly requirements, units and other properties are defined in the drawing template. In this section you will use the default drawing template.

The sheet format is incorporated into the drawing template. The sheet format contains the border, title block information, revision block information, company name and or logo information, Custom Properties and SolidWorks Properties. Because this section of the book is a Quick Start section, you will not address these items at this time.

Custom Properties and SolidWorks Properties are shared values between documents. Utilize an A-size Drawing Template with Sheet Format for the Gear assembly drawing.

A drawing contains views, geometric dimensioning, and tolerances, notes and other related design information. When a part or assembly is modified, the drawing automatically updates. When a dimension in the drawing is modified, the part or the assembly is automatically updated.

**Tutorial: New Drawing - Gear 1-4**

Create a New assembly drawing named Gear. Display the Front, Top, Right, and Isometric views. Utilize the ModelView command in the Drawings toolbar.

1. Click **New** from the Standard toolbar.
2. Double-click the **Drawing icon** from the Templates tab.
3. Select **A-Landscape** from the Sheet Format/Size dialog box.
4. Click **OK** from the Sheet Format/Size dialog box. The Model View PropertyManager is displayed.

5. Click **Cancel** from the Model View PropertyManager. The Draw1 FeatureManager is displayed. Set the Sheet1 Properties in the drawing.

![Model View PropertyManager](image)

💡 The Model View PropertyManager is displayed if the Start command when creating new drawing option is checked.

6. Right-click in **Sheet1**.
7. Click **Properties**. The Sheet Properties is displayed. Draw1 is the default drawing name. Sheet1 is the default first sheet name. The Control Area alternates between Drawings, Sketch, and Annotations toolbars. The Model View PropertyManager is selected by default.

8. Select Sheet Scale **1:1**.
9. Select **Third angle** for Type of projection.
10. Click **OK** from the Sheet Properties dialog box. The A-Landscape paper is displayed in a new Graphics window. The sheet border defines the drawing size, 11” × 8.5” or (279.4mm × 215.9mm). The Drawings toolbar is displayed in the CommandManager.

Set the Document Properties.

11. Click **Options** from the Standards toolbar.
12. Click the **Document Properties** tab.
14. Click **Units**.
15. Select **MMGS** (millimeters, gram, second) for Unit system.
16. Enter **2** for Length units decimal place.
17. Enter **0** for Angular units decimal place.
18. Click **OK** from the Document Properties - Units dialog box.

💡 Detailing options provide the ability to address; dimensioning standards, text style, center marks, extension lines, arrow styles, tolerance and precision.

Save the drawing.

19. Click **Save**. Enter **Gear** for file name.

20. Click **Save**. The Gear drawing FeatureManager is displayed.

21. Click **Drawings** from the Control Area. The Drawings toolbar is displayed.

22. Click **Model View** from the Drawings toolbar. The Model View PropertyManager is displayed.

23. Double-click **Gear** from the Model View PropertyManager. Insert a Front, Top, Right, and Shaded with Edges Isometric view.

24. Click **Multiple views** from the Number of Views box.

25. Click *Front, *Top, and *Right from the Orientation box. Note: Isometric view is selected by default.

26. Click **OK** from the Model View PropertyManager. The four views are displayed in Sheet1.

27. Click **Yes**.

28. Click inside the **Isometric view boundary** in Sheet1. The Drawing View4 PropertyManager is displayed.

29. Click **Shaded With Edges** from the Display Style box.

30. Click **OK** from the Drawing View4 PropertyManager. View the four created views.

31. Click **Save**.
Insert a Bill of Material into the Gear assembly drawing.

A drawing can contain a table-based Bill of Materials or an Excel based Bill of Materials, but not both.

32. Click Insert ➤ Tables ➤ Bill of Materials from the Main menu. The Bill of Materials PropertyManager is displayed.

33. Click inside the Front view, Drawing View1. View the mouse pointer icon feedback symbol.

34. Click Top level only from the BOM Type box. Accept all other defaults.

35. Click OK  from the Bill of Materials PropertyManager.

36. Click a position in the top left corner of Sheet1 to position the Bill of Materials as illustrated.

37. Click OK  from the Bill of Materials PropertyManager.

38. Click inside Sheet1. Bill of Material1 is displayed in the FeatureManager. The Bill of Materials and Title block are incomplete. Complete the Gear drawing later as a homework problem.

39. Click Save .

40. Click Windows ➤ Close All from the Main menu.

41. Click File ➤ Exit from the Main menu to close the SolidWorks session. You are finished with Chapter1. Review the SolidWorks Tutorials for additional information on parts, assemblies, and drawings.

Summary

In this chapter you learned about a Base sketch, Base feature, Extrude Cut features, refining the design, associativity, drawings, and geometric constraints. You started a SolidWorks session, and applied the SolidWorks User Interface (UI) and CommandManager.
You created the Standoff2 part using the Extruded Base/Boss feature with the Mid Plane End Condition option in Direction 1. You created an Extruded Cut feature with the Through All End Condition option to complete the part. You applied dimensions and modified these dimensions. You applied color to your part using the Color and Optics PropertyManager.

You created the Gear assembly with two components: Standoff2 and Gear28. You fixed the first inserted component to the Origin. You inserted the second component and then inserted a Concentric and Distance Mate.

You created an assembly drawing with a Front, Top, Right, and Isometric view. You modified the Isometric view with a Shaded with Edges Display Style. In the drawing you inserted a simple Bill of Materials. You have completed the first chapter of the book.

In Chapter 2, you’ll learn more features and sketching techniques required to create a Cover part and a Gear part used in the VEXplorer model.

---

**Key terms**

- **Associativity.** Assures that changes incorporated in one document or drawing view are automatically made to all other related documents and drawing views.

- **Base feature.** The first feature of a part is called the Base feature.

- **Base sketch.** The first sketch of a part is called the Base sketch. The Base sketch is the foundation for the 3D model. Create a 2D sketch on a default plane: Front, Top, and Right in the FeatureManager design tree, or on a created plane.

- **ConfigurationManager.** Located on the left side of the SolidWorks Graphics window is a used to create, select, and view multiple configurations of parts and assemblies in a document.

- **Constraints.** Geometric relations such as Perpendicular, Horizontal, Parallel, Vertical, Coincident, Concentric, etc. Insert constraints to your model to incorporate design intent.

- **Coordinate system.** A system of planes used to assign Cartesian coordinates to features, parts, and assemblies. Part and assembly documents contain default coordinate systems; other coordinate systems can be defined with reference geometry. Coordinate systems can be used with measurement tools and for exporting documents to other file formats.

- **Design intent.** Design intent is the intellectual arrangements of features and dimensions of a design. Design intent governs the relationship between sketches in a feature, features in a part, and parts in an assembly.

- **Design Library.** Located in the Task Pane, the Design Library provides a central location for reusable elements such as parts, assemblies, etc.
• **Drawing.** A 2D representation of a 3D part or assembly. The extension for a SolidWorks drawing file name is .SLDDRW.

• **Document.** A file containing a part, assembly, or drawing.

• **Features.** Individual shapes created by Sketch Entities tools: lines, circles, rectangles, etc. that when combined, creates the part. Features are geometry building blocks, they add or remove material, and are created from 2D or 3D sketched profiles or from edges and faces of existing geometry.

• **FeatureManager design tree.** Located on the left side of the SolidWorks Graphics window and provides an outline view of the active part, assembly, or drawing. The FeatureManager design tree and the Graphics window are dynamically linked. You can select features, sketches, drawing views, and construction geometry in either pane.

• **Fly-out FeatureManager design tree.** Allows you to view and select items in the PropertyManager and the FeatureManager design tree at the same time.

• **Extruded Boss/Base.** A feature that adds material to a part or an assembly.

• **Extruded Cut.** A feature that removes material from a part or an assembly.

• **Parameter.** A value used to define a sketch or feature, often a dimension or instance.

• **Rollback.** Suppresses all items below the rollback bar.

### Check your understanding

1. Identify the following feature icon 📀.

2. Identify the following feature icon 🌿.

3. Identify the following sketch icon 🗓.

4. Identify the following sketch icon 🗝.

5. Identify the number of instances in the illustrated model.

6. SolidWorks provides system feedback by attaching a symbol to the mouse pointer cursor arrow. The following system feedback symbol ☰ indicates a _____.

7. The following system feedback symbol ☰ indicates a _____.

8. In a SolidWorks session, the first system default part filename is named _____.

9. SolidWorks attaches the ______ suffix to a part document.

10. SolidWorks attaches the ______ suffix to an assembly document.

11. SolidWorks attaches the ______ suffix to a drawing document.
12. Describe the Base feature.
13. Describe the Base sketch.
15. Describe a component.
16. Describe a Coincident Mate.
17. Describe a Distance Mate.
18. True or False. Mates remove degrees of freedom from a component. Mates reflect the physical behavior of a component in an assembly.
19. True or False. The FeatureManager provides a summarized view of the active part, assembly, or drawing. The FeatureManager displays the details on how the part, assembly, or drawing was created.
20. True or False. Constraints are geometric relations such as Perpendicular, Horizontal, Parallel, Vertical, Coincident, and Concentric.
21. True or False. The (f) symbol next to the component name Cover_Hole<1> means first component.